Ir para o conteúdo principal

Model A1312 / Mid 2010 / 3.2 GHz Core i3 or 2.8 & 3.6 GHz Core i5 or 2.93 GHz Core i7, ID iMac11,3

383 Perguntas Visualizar todos

CPU fan full speed showing 0rpm


a couple of days ago I tried to change my Seagate hard drive for another Seagate but with 3Tb and also install a SSD drive in place of the optical drive.

I thought everything went quite well during the installation but when I finished it turned out that the CPU fan was going crazy. I checked several posts and seen that other people complained about fans going crazy and it was due to some sensor not working, so I tried several things but none of them with result:

  • Connect the optical drive sensor to the LCD sensor socket to see if that was the problem.
  • Connect the optical drive sensor to the HDD sensor socket.
  • Same as before but also connecting HDD sensor to LCD sensor socket.

None of them seemed to work so I ran AHT and I got this results:

  1. 4MOT/4/40000003 HDD-1416
  2. 4MOT/4/40000003 HDD-1422
  3. 4MOT/4/40000003 HDD-1426

So I thought that it was worth checking if all fans and connectors were working. I first unplugged the ODD fan and connect it to the HDD fan and it worked fine, did the same connecting it to the CPU fan and seemed to go like crazy, but worked.

Finally I decided to unmount the HDD fan and plugged it to the ODD connector and surprisingly it worked.

Then I tried to limit the fan max speed via programs like SMCFanControl or SSDFanControl but with no luck, all of them reported that the CPU fan speed was 0rpm and it's the one going crazy.

So.. my problem I'm totally lost. I don't know if it's worth buying a new HDD fan and see if it might solve my problem or if I might take the same route as others and hack the CPU fan, or maybe change the logic board...

Any ideas?

Respondido! Ver a resposta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 5
3 comentários

I am currently having this exact issue. The bottom left fan is the one that's running full speed, after I swapped out a bad logic board. Could it be that the new logic board is bad? SSD Fan Control shows the CPU fan speed at 0.


Some years later, I also replaced a hard drive in a mid-2007 iMac with an SSD and got the same symptoms: fans running at 100%, sensors reporting 0 rpm. However, in my case, the culprit was the CPU Fan connector being loose. Reconnected it, problem vanished. Replaced the CPU a few days later, still no problem.

That can cause the problem, too.


Please use the OWC part when replacing the original HDD with either your own HDD or SSD: OWC In-line Digital Thermal Sensor for iMac Late 2009 - Mid 2010 HDD or SSD Drive Upgrade. Many newer HDD''s don't offer the header for the Apple thermal sensor and unless you are putting in the exact same drive the sensor cable will likely not mate up with the correct contacts as each drive maker does things a bit differently.

In the case of SSD's they don't offer the needed connections at all so you must use the OWC part (when mounting it in place of the HDD)

We strongly recommend not using fan control software as it can mask other problems and over rev your fans wearing them out prematurely!


Adicionar um comentário

5 respostas

Solução escolhida

Apple used a proprietary heat sensor on the hard drive of this machine. Use an OWC In-line Digital Thermal Sensor for iMac 2009-2010 Hard Drive Upgrade to cure this problem

OWC In-line Digital Thermal Sensor for iMac Late 2009 - Mid 2010 HDD or SSD Drive Upgrade

Esta resposta foi útil?

Pontuação 4

15 comentários:

but what does this have to do with the fan of the cpu ??


fatboy without it, if you put in an off the shelf drive you will get a runaway fan.


dear mayer,

I first replaced the hard disk of the mac with a wd 3tb, the fans went to maximum but I installed mac fun and everything went fine. then I decided to change the cpu from i3 to i7 and I added a ssd, with the ifixit kit leaving installed the dvd and from that moment the fan of the cpu goes to the maximum, why ?? I tried to bring everything as it was but the fan always goes to the maximum, can you help me?


in most mac fans says that the fan speed is 0rpm


fatboy Read my original answer!


Exibir mais 10 comentários

Adicionar um comentário

I would check to see if you lost a resistor in the process. Seems common that if you have a CPU fan which reads 0 rpm but seems to be going full blast, there's likely an issue with the circuitry on the logic board. What a few people have found in another thread is that there's a 47KΩ resistor which is missing near the power button connector. If you have one missing from there, all you need is a new resistor and your Mac will function CORRECTLY because it knows the fan speed. Link: CPU Fan runs at full speed.

Esta resposta foi útil?

Pontuação 2

2 comentários:

I have been browsing a lot of forums because I encountered the exact same issue (all temps sensors working and showing normal temps, CPU fan at full speed but reporting 0rpm in iStat) after removing my 27" mid-2010's logic board to swap the core i3 550 for a core i5 760. I salvaged a 25k resistor from a dead laptop and soldered it in place (just on top of the power button connector) and even if it's not the correct value, it immediately fixed the issue and iStat now reports around 1000 rpm idle. We will see if it lasts.

Here is a picture of my logic board with the missing resistor :

Thanks a lot for pointing out the source of this issue.


Thanks this (and a tiny piece of gummy adhesive fixed it! Woohoo!


Adicionar um comentário

You're right you have a sensor issue. The sensor reports to the EFI that it can't detect/control the FAN so the EFI runs the fan at full throttle (by default in scenarios like this) to keep you from cooking your CPU.

I don't know if you damaged the connector, blew up the sensor but the error is basically saying it believes your FAN MOTOR (4MOT) for the HD (HDD) is out of spec. and the amount it's wrong is the last set of numbers in RPM (I suspect too slow - hence kicking it into overdrive).

MAYBE you need an EFI update to run that drive? What is it's SATA Speed (your bus is 3Gb/s Max)

Have you tried an SMC reset?

If this answer is acceptable please remember to return and mark it.

Esta resposta foi útil?

Pontuação 1

9 comentários:


the hard drive that the machine currently has it's the original one, so it should be supported and it seems that I have the latest EFI as I can see from the apple page.

I have tried an SMC reset but I'm not sure I succeeded, is there any way to double check that the SMC reset was done properly? Should I see some side effects like bluetooth keyboard not connected or something like this? Reinstalling the EFI may trigger the SMC reset?

On the other hand, can replacing the FAN help to solve the problem in case there's a real issue with it and it's too slow?



Is it possible that the cpu fan is broken? iStat pro shows me that cpu fan is at 0rpm and other programs too, is that normal?


I think the sensor for CPU is blown. You said "...did the same connecting it to the CPU fan and seemed to go like crazy, but worked." What I'm understanding from your report is that the ODD fan (the only one you checked on the CPU connection) went crazy at that terminal. You didn't say how the CPU fan acted on the ODD connector... or if you checked the HDD Fan with the same or different results. So. if two fans connected to that terminal both run at High Speed, and the sensor says CPU fan is 0 then the CPU sensor is obviously shot.


The fan also has a tachometer feedback. Are you sure HD fan is working correctly? As you state it is reporting zero RPM. I would start by trying a new fan first here.


Hello, I ordered new HD fan to be able to change it and see if the At still reports an error there. I'll receive it next week and I'll keep you guys posted.

I'm hoping that AHT would report me a CPU fan problem if it was there, but we will see


Exibir mais 4 comentários

Adicionar um comentário

I'm having the same issue, although its not immediate and istat shows ~1400 RPM before the issue occurs. then when it occurs, the fan goes to full speed and shows 0 RPM. i am not knocking my iMac at all. it just seems to happen on its own during use

Esta resposta foi útil?

Pontuação 1

1 comentário:

@Andrew - How about creating a fresh question with your details. As you can see Steve's Q just above never went very far as it was hidden like yours in an old question


Adicionar um comentário

You might be able to use SSD fan control and set it for manual 3000 RPM - it's a coping mechanism until the problem can be solved.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

slope será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 12

Últimos 30 dias: 51

Duração total: 10,021