Ir para o conteúdo principal

(While Driving) Sluggish, Lost Power, Transmission?

I own a Chevrolet Tahoe 1999, 4x4 5.7L engine truck. She is my baby, I have already replaced a few things on her, i.e. radiator, O2 sensor, starter, positive terminal from battery to starter. I bought it from New Hampshire (I live in MA), the title has one owner, bought in 1999. 156,650 miles on it currently. When I drive, I feel something weird from the engine, once I accelerate, it kind of drops in power/speed. Hard to explain, but also when accelerating it just feels sluggish, it just doesnt feel right. I checked the tranny fluid, color checks out, the smell I'm not too sure of, but I was wondering if anyone could possibly give me a few tips or suggestions, I've searched high and low on the web for possibilities but nothing really hits the nail on the head. THANKS!

Respondido! Ver a resposta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 1

Comentários:

Are there any current or pending dtc's? Check engine light on? If so, what are the codes? There are just too many possibilities. Need more info.

Kevin

por

Adicionar um comentário

2 respostas

Solução escolhida

Quite possibly in need of a new fuel pump.

I had exactly the same symptoms on mine and the new fuel pump fixed it.

Could also be the injectors if your car smells of petrol.

Check the fuel pressure at idle and under acceleration, should be 52PSI and 68PSI or thereabout respectively.

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

This video should help you out.

YouTube - CLEAN THROTTLE BODY

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Jasmine será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 1

Últimos 7 dias: 6

Últimos 30 dias: 30

Duração total: 15,004