Ir para o conteúdo principal

Introdução

If your RX100 camera is showing the error, "Turn power off and then on" and the lens will not retract completely, see below for the simple fix.

My RX-100 started showing this error message, and initially was able to turn off/on and shoot photos, but after a few days it was constantly showing the error and would not work any more. The lens barrel remained partially retracted and would not fully extend. There is no reset button.

I found a simple fix via an internet search, partly in German I believe. This little fix saved me $300 and a lot of hassle.

Peças

Nenhum componente especificado.

    • Turn off the power.

    • Remove the 5 small screws on the bottom panel.

    • Lift off from the narrow end on the battery panel side. You may have to open the battery cover. The other end is hooked to the body. There are also 2 small tabs on the mid front side.

    • Remove the 2 screws on each side, total 4.

    • Gently separate the back panel and front panel. You do not need the separate the panels completely.

    • With battery in, power on and it will start up and the lens barrel will extend fully as it should.

    • Turn power off and it should retract completely and lens cover should also close.

    • Replace 4 screws on the side, and hand tighten.

    • Replace the bottom panel, wide end with hook and 2 small tabs on the mid front side in and replace the 5 screws, again hand tighten.

Linha de Chegada

25 outras pessoas concluíram este guia.

Cherry

Membro desde: 01/01/2016

681 Reputação

5 Guias de autoria

91 comentários

I tried the fix TWICE.

After each re-assembly, the same problem happened.

Any ideas on alternative fixes?

With on-line repair service priced at $300 (July 2016), is there any reason to keep the camera?

jvbeaupre - Responder

I tried the fix at least 5 times…same problem as Guide / jvbeaupre...

phwaeger - Responder

It actually works, but only as long as I keep the camera disassembled. Once I put it back together again, the same problem re-occurs. It looks clean, but is there something in particular I should look for? Something that I should try to avoid "squeezing" when assembling?

Niklas James - Responder

Hi Niklas,

had the same issue. I remove the panel at the bottom and it works for a while - but - as you can read, a workaround is less as a fix ( ;

Cherry -

Did you find a resolution? I just started receiving this error message and before I start removing screws and panels, I'd like to know if you had success. Thanks so much.

Carol Mitch - Responder

Adicione um comentário

Exibir estatísticas:

Últimas 24 horas: 7

Últimos 7 dias: 55

Últimos 30 dias: 236

Duração total: 35,178