Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

855 Perguntas Ver todas

Keyboard will not light up

Since installing Snow Leopard my keyboard will not light up in any light conditions be it completely dark in the room or not. When I place my hand over the ambient light sensor the screen still dims as it should but the keyboard does not light up. I have checked that it is set to 'illuminate keyboard in low light conditions' in keyboard settings and have tried toggling F5 and F6 keys which show keyboard light icon increasing and decreasing as if the backlighting was working. I have completed another fresh install of SL, repaired disk permissions and reset the PRAM but all to no avail. It worked perfectly while running Leopard. Does anyone have any other ideas I could try or is it a trip to the Genius bar? Cheers, Ray

Respondido! View the answer Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0

Comentários:

i have this same problem, what does the connection look like?

por

Adicionar um comentário
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

4 Soluções

Solução escolhida

Just for future reference,if anyone experiences this particular problem then I recommend a quick trip to the Genius bar. They opened up the MBP and quickly reconnected a loose connection that was the cause of the issue. The guy mentioned that the only other reason this could have happened would be as a result of a hardware failure of the back lighting unit which would have taken a lot more time to repair (and it would be chargeable if out of warranty obviously). The reconnection they did for me was free of charge and took 5 minutes to fix.

Esta resposta foi útil?

Pontuação 2

Comentários:

How did the cable became disconnected?

N.

por

I had the MBP delivered by courier to a job I was working at. Even although it was properly packaged in it's original box the movement during transportation must have shaken the connection loose. The box was not damaged in any way so I can safely assume it was not manhandled and it was also marked as fragile on the outside of the package. As I did not notice for a day or two I put it down to a bug after installing Snow Leopard but that was obviously not the culprit in the end.

por

Adicionar um comentário
Resposta Mais Útil

not to worry! i found the answer on the apple support threads. it's a teeny, tiny thing right beside the RAM itself. you have to pull up and even small latch that's on the back of where the connection plugs into.

you can see it here:

http://i1220.photobucket.com/albums/dd45...

Esta resposta foi útil?

Pontuação 3

Comentários:

+ good thanks for the photo

por

This was the answer for my problem. Mine was slightly loose and crooked. I only straightened mine and put a little finger pressure, reassembled the lid and the keyboard light works now. thanks for the post.

por

Adicionar um comentário

Sorry Jake, I have no idea what ithe connection looks like. The Genius guy took my MBP to the repair area to diagnose what exactly was causing the issue. I suggest you take yours to an Apple store if you can or post a new thread here on ifixit to see if anyone else can advise you.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

I ran into this same problem. It was driving me crazy. I tested keyboards (known working) back and forth between multiple machines. I also tested and (unnecessarily) swapped the light sensor on the left I/O board as a last ditch effort. Mind you, I have another working "parts machine" that I am able to test on. Absolutely everything worked - the keyboard, the sensors, etc. I was at a complete loss, and thought something MUST be wrong with the logic board, although everything else worked fine.

As an absolute gamble and merely wondering what might happen, I started up from an external drive, and viola! All of the sudden the keyboard backlight worked! For me, it was simply a bad install of the OS.

I re-installed the OS, and now everything is working.

So, one thing you might consider is this: install the OS on an external drive (to avoid reinstalling on your main drive.) Start up from the external drive to see if that makes the difference (plug in the drive and hold in the option key at startup.) If that solves the problem, re-install the OS.

Esta resposta foi útil?

Pontuação 0

Comentários:

Also, fyi - the connection mentioned above is a great solution. However it does not exist on all models. I know for certain it does not exist on the MacBook Pro Santa Rosa 2.2GHz or the 2.4GHz. I assume the connection does not exist on any of the Santa Rosa models (pre unibody).

Thank you all for the help. I was losing my mind!

por

Adicionar um comentário

Adicionar a sua resposta

peelywally será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 3

Últimos 7 dias: 27

Últimos 30 dias: 104

Todo: 14,390