Ir para o conteúdo principal

Repair guides, support, and troubleshooting information for the first 13-inch MacBook Air to feature Apple's Arm-based M1 SoC (with an 8-core CPU and up to an 8-core GPU). Released in November 2020 and identified by model numbers A2337 or EMC 3598.

159 Perguntas Visualizar todos

M1 MacBook Air A2337 stuck in boot loop, can't DFU revive or restore

First look at some short videos to see how bad it is right now:

  1. How the machine is stuck inside a boot loop now 
  2. How the machine failed the revive and restore operation by Apple Configurator

TLDR, what happened?

Last month, my M1 MacBook Air was once stuck at 5V with no power and couldn't boot. I ended up finding a blown capacitor, and I fixed it successfully. The board had once been completely fixed and successfully booted into the MacOS login screen.

Because of my extreme BAD LUCK (and arrogance) :(, before reassembling the machine, I decided to check all the voltages again using the multimeter. Then I accidentally shorted two points very close to each other (PP5V_S2 and PPBUS_5VS2_VIN). I saw a small spark, and heard a tick sound. Later I found that the machine still rebooted, but was then trapped inside a restore boot loop. I went to the Apple repair center, they tried to revive, wipe, or retrieve it, but they all failed :(. I can’t even hold the power button to turn the machine off. All I can do now is to hold ctrl+option+R-shift+power to put into DFU mode to force stop the boot loop.

For the current situation please watch the YouTube videos above.

Main observation up to now:

  1. Power button mis-behavior, doesn’t power off, doesn’t bring up any recovery options. Please watch this video
  2. Apple Configurator failed to revive or restore any firmware or OS, but no error was shown, please watch this video
  3. The speakers sometime sound at the start of the boot loop, but not always
  4. Trackpad is normal, haptic feedback is on
  5. Keyboard is fine, can put machine to DFU mode
  6. Closing the lid does not turn off the monitor. It is always in the boot loop with display on, unless I put it into DFU mode
  7. Power conditions seems normal, USBC pulling 20V, diode mode voltage drop to ground all seems normal (the machine has once been fixed completely)

Now I can only think of these areas of potential problem:

  1. The firmware chip
  2. The NAND chips
  3. The T2 chips (or something equivalent for M1?)
  4. Any pull-up or pull-down resistors blown on the signal rail

Questions:

  1. What damage do you think shorting PP5V_S2 to PPBUS_5VS2_VIN can cause?
  2. What diagnosis steps can I take to confirm if the firmware/NAND is really OK or really dead? So that I can rule out some possibilities.
  3. I have a feeling that capacitors/resistors are easier to go bad than those chips, as they usually stand at the frontline. E.g. Can a bad pull up or pull down bad resistor actually cause this boot loop?

Now going into the details, long version of the story

As a hobbyist repairman, I have got the schematic and the parts pdf file. Also I have a multimeter and a soldering iron. At first, what I did to locate the blown capacitor was to measure the diode voltage drop to ground for some essential rail, then compare it to OpenBoardData.org . This quickly pinpointed the blown capacitor as C81D8, which shorted the PP3V8_AON_VDDMAIN rail to the ground. Removed it, back normal voltage, and the machine booted to the MacOS login screen. This proved that the machine has been completely fixed, at least once.

Very Very sadly, I decided to check the voltage again before assembling back. When I was checking PP5V_S2 rail on CC337, I accidentally slid the probe into the upper component CC350, creating a short circuit to PPBUS_5VS2_VIN. I could see a small spark, I also heard a tick sound. And then the USBC meter goes off and back on, indicating the board was rebooted. This brought me into the current situation. The machine can get 20V successfully, but when the machine is powered on, I see Apple login for one second, immediately turning into a circular logo with an exclamation mark, with a link to support.apple.com/mac/restore . When holding the power button, it says “continue holding for startup options”, then it will say “loading startup options”. Normally this should get me into recovery, but it won’t. It will just restart itself after this. The power button also can’t power off the machine. I need to hold ctrl+option+R-shift+power to put into DFU mode to force stop the boot loop. Or just unplug the battery for now.

I went to the Apple store the next day. The staff first put my machine into DFU, and succeeded. The Apple Configurator shows the DFU logo. They first tried to revive it, but failed. Then they went all the way to restore, the machine stopped the boot loop, and then went into the apple logo with progress bar. But after the progress bar was completed, the machine auto rebooted and got back into the restore screen loop again. It looks like nothing has ever been written into storage (but it appears to be as the reviving machine shows everything as normal). Those staff just say the board is damaged and needs to be repaired (for half of a new machine price), and I definitely won’t do it.

This is just too sad. I just don’t want to give up. Now I just can’t accept the reality, I fixed the machine once, and then immediately broke it again. But I still don’t want to give up. I have checked all the rails directly connected to the firmware chip (UF260), diode voltage drop to ground all looks normal. Then I checked most of the rails directly connected to the two NAND chips, all seemed quite normal. The machine can output screen, boot sound, keyboard is working (it can put machine to DFU mode), and the haptic feedback for trackpad also works.

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário

2 respostas

Sorry to hear this happened :( very unlucky and props for repairing the original issue! The DFU revive error wasn't clear from the video. Do you have access to a Mac to attempt DFU revive again? It should either succeed (and show a lock symbol) or fail and show an error message.

Also, what is the current voltage on PP5V_S2? And is PP5V_S2_PGOOD present?

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Similar thing happened to me. DFU won't work, it says device not booted. My screen is very dimmed, I need the flashlight to see what's going on there, but it shows the Apple Logo if I try to boot it in Restore, or the Exclamation point in the circle if in DFU or any other mode.
I got error 21 a couple of times too! I need my files back, be it data recovery or anything...this all happened because of 13.6.1 update, everything was fine before

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Ibrewcoffee Onthemoon será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 2

Últimos 7 dias: 32

Últimos 30 dias: 95

Duração total: 214