Ir para o conteúdo principal

Model A1419 / Late 2012 / 2.9 & 3.2 GHz Core i5 or 3.4 GHz Core i7 Processor, ID iMac13,2

328 Perguntas Visualizar todos

27” 2012 iMac not power up - dead

After years of use, the device made an electronic noise while I was sat at the desk and immediately went off. Device will not power up now.

I’ve tried different power sources, holding in the power on, removing the RAM and replacing in various combinations.

It seems to be a power related problem but I’m not expert, welcome advice including ultimately where I can take for repair (Live in Lincoln, UK).

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 1
1 comentário

@joeemmerson when you say you've tried different power source, are you referring to different power supplies? That is what I would start with.

por

Adicionar um comentário

1 resposta

Pergunta mais útil

The best shop in the UK is in Liverpool TheBookYard About a three hour drive for you. But well worth it! They maybe able to fix it as you wait.

Esta resposta foi útil?

Pontuação 4

5 comentários:

Thanks for the advice. Will keep in mind.

por

Thanks.

I did some further investigation as I have another iMac. Used the working iMac’s power cable on the poorly iMac and no joy. Used the poorly iMac’s cable on the healthy iMac and not joy. Also checked the fuse on the poorly iMac cable / socket and it had blown so perhaps pointing toward a power source problem on the iMac.

por

@y4ojv4wm5omavi - Yes, the internal power system is what I expect has failed. It sounds like the socket and/or cord has a short as well. Which explains the outlet fuse burning.

To test the bad cord use a Ohm or continuity meter to measure across the outlet pins with the cord unplugged fully.

There should be no connection across the plug pins 🔌 you may want to inspect the systems socket for burn marks as well as check the cords connection end to end from each line within the cord.

por

Oh wow! Never heard of them before, only a train ride away from Liverpool so I might give them a look 👀

por

Hi. Problem solved, https://computerclinik.co.uk from Lincoln were excellent in diagnoses and fix. Turns out after years of use the dust in the back had accumulated to such an extent the power source ultimately overheated. Replacement of this and everything is back as it was.

Thanks to all for suggestions.

por

Adicionar um comentário

Adicionar a sua resposta

Joe Emmerson será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 1

Duração total: 54