New Idea: On/Off Remote for iPad - but iPad can't boot! Suspect SENSE

Hi folks,

I am installing a mini remote controlled switch in the iPad 8th Gen. The ideas is to be able to cut the power to the iPad at the battery using a remote control.

1st attempt:

I wired up the remote control receiver inside the iPad. 4 pins, positive, negative, output + and output -. Fairly simple. Positive and negative are wired to the battery terminals. Output + and output - are wired to the motherboard terminals.

1st attempt result: Remote control worked fine, but the iPad was booting and then shutting off when I tried to open Safari or something. I thought it had to do with the max current that the mini remote couldn't handle (~1A on my multimeter). Later the iPad stopped booting on the last screen (same as the remaining attempts).

2nd attempt:

I wired up the remote control receiver to a relay. The relay will handle the current in normally closed configuration and will only be activated by the remote control switch. Therefore - any large amp operations should be handled thru the relay, and everything should work.

2nd attempt result: relay worked fine, remote control worked fine, but the iPad wouldn't boot fully. It would boot up until the last screen and then shut down. Same as attempt #1.

3rd attempt:

I removed the relay and remote and left the copper tape wiring in place. Everything worked with a short wire run (board + connected to battery + on the breadboard, board - connected to battery - directly using copper tape).

Then I made some minor adjustments:

I installed the relay and the remote, it stopped working (boot issue).

I removed the remote and just left the relay, still not working (boot issue).

I measured the voltage drop caused by the relay, around 0.12V.

I moved the board + and battery + pins farther apart on the breadboard. Voltage drop ~0.04V. Not working (won't boot).

I then swapped to a different copper tape template that I had been using for awhile and it still wouldn't work, even with the same wiring.

I suspect it is due to the SENSE pin on the battery that relays the battery voltage to the motherboard. I am "stealing" voltage from the battery (thru the relay, wiring, & remote) before providing it back to the board, so there will be a mismatch, albeit small, between what the SENSE is providing at the battery and what my circuit is providing back to the board.

Am I correct in my reasoning? Anywhere else I could potentially (safely) interrupt the iPad circuit besides the power back to the board, to be triggered by the remote? Any other ideas on how this could work?

See my basic schematic below:

Block Image

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário