Ir para o conteúdo principal

The APC RS 1000 is an uninterruptible power supply capable of delivering 600 Watts.

6 Perguntas Visualizar todos

APC UPS Rs1000 not charging batteries when plugged in on the wall

I found an old APC RS1000 UPS with dead batteries on my storage which I decided to bring back to life so I opened it to replace the dead batteries with fresh new ones.

Problem seems to be when I plug it to the wall, click the ON button for 2 secs, the green light blinks, then the solid ON BATTERY stays forever.


So it runs only from batteries. Not from the wall.

Thinking the circuit breaker may be burned or just malfunctioning, is this something I can just replace? I tried to search using common keywords with and without the brand with no luck.

Any tips will be welcome.


Thanks!

NOTE: All these tests performed WITHOUT any device plugged to the UPS!

Mise à jour (02/02/2023)

And finally I'm attaching these hi res pics of MY OWN UPS main board just in case you spot anything I may be missing. To me everything looks OK and in good shape, AFAIK this ups was fully working before getting stored and the only issue was dead batteries but.... You tell me??

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Update (02/02/2023)

Well let's see, first things first, ive read over the Net that these prongs do pop-up a lot but I don't have any reference so I don't know if the below is a standard or an activated circuit breaker....

Wdy think?

Block Image

Update (02/02/2023)

Next thing I've done is check continuity in these 2 poles, and the multimeter beeped, so I guess it's OK and working, in the locked position "as it is" now?

Block Image

Update (02/02/2023)

Then I've checked for 220V (I'm in EU) on the upper right corner connectors and they do read 220V so I'm assuming the fuse is working and protecting the circuit so far (aka not "fused").

Am I right till here?

Block Image

Update (02/02/2023)

So, considering the AC reaches the main board past the circuit breaker, I'm at a loss now since I'm not an electronics pro to read the service circuits mapping...

Googling a bit further i found this article:

https://vasvir.wordpress.com/2021/02/15/...

Which for the Rs1000 mentions the change of 3 capacitors.

So my next question is:

Is there a safe way to test if these capacitors are in working order and if there is (multimeter?) how do I perform the check?

Excuse my ignorance once more!

(apparently this is the image of the Rs1000 main board if you feel you need to point me anything out :))

Block Image

Update (02/06/2023)

I'll thank any further input on troubleshooting this. Thanks!

Update (02/19/2023)

Some more tests, each one gets me more confused!

WITHOUT the unit plugged to the wall, setting the multimeter to CONTINUITY, instead of BEEPs from the Multimeter, I get these values on its screen:

Block Image

The one in the middle produces NO reading and NO beep on the multimeter :?

Then setting the multimeter to DC, I get the following:

Block Image

THEN, PLUGIN the unit on the wall and turning on the UPS, I get this:

https://www.dropbox.com/s/fjnlawpi12hcqz...

Any insights?

Update (02/26/2023)

So is it normal that plugged on the wall, with the unit turned OFF I'm getting voltage in the battery connectors? And if so, it means batteries do charge. And if so, what else is not acting so the AC does not kick in while there's wall power??

Block Image

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 2
19 comentários

alextc, I’ll just start by saying: It’s much better to update your original question with new information and pictures, and not flooding the question with answers, that aren’t answers, but updates from OP.

Capacitors can be a contributing factor (electrolytic caps). The only way to test them, is to use an ESR (Equivalent Series Resistance) meter. Those can be found on Amazon for ~$20 + shipping. If you have a decent multimeter, you can test the capacitance, but that will unfortunately not tell you much. You should do a thorough visual inspection of the caps for: leaking, bulging / blown tops and general damage. I don’t see anything that jumps out on the pictures, off hand.

When working on electronics, having an ESR meter is invaluable!

por

Thanks for the tips! I rarely use/repair this type of equipment to this level but I'm a bit !#^&@@ as I do remember this unit working fine but only batteries were dead on storage :( Seems I was wrong.

I can't find anything bulging or blown from visual so... I'm pretty much f*cked up at this point I guess....

Unless anyone from Europe can take a look to the board itself if I ship it?

por

2 of the capacitors mentioned, C40 & C41, are in the charge pump which generates -8V for IC8 which is the line sense op amp. If -8v isn't there, there is no line sensing and it will only run on battery. Are you getting any beeps? - that is what drives the charge pump. If there are no beeps then it is in IC7 circuit. If there are beeps, it is in the charge pump. Likely C41 - the black cap. If you can run it opened up and are comfortable with that, measure the -8V on the - side of C41. If there is -8V, then it is in the line sense IC8 circuit.

por

@ruggb When I first turned it on after battery replacement, there were no beeps, as batteries kicked in.

On a couple further switch on's, now it starts to beep, but my guess it's related to the batteries being almost discharged (as they were not charged in first instance upon recieving them from the store).

So aside from the "batteries drain" beeps, I'd say there's nothing wrong with the system (aside of it not running from AC of course).

So I should get -8V on the C41 legs you say?

por

@alextc yes, without that -8V the AC sense circuit doesn't work. Since you have beeps, the charge pump should be driven.

So, you are also saying the charging circuit is working, right?

por

Exibir mais 14 comentários

Adicionar um comentário

6 respostas

Pergunta mais útil

@alextc

Good place to start is with the service manual and use the schematics to try and find out what's wrong.

You said that it ".... runs only from batteries. Not from the wall." so presumably since it works OK in this mode you may have to start checking the AC input side of the UPS

Esta resposta foi útil?

Pontuação 3
Adicionar um comentário

Have you tested for shorts yet? That would be the first thing I would check. If you verify the only flaw is the circuit breaker then you can remove it and usually pull the numbers from it to search for them directly. You could have a bad connection or a bad wire that is causing your problem though.

Esta resposta foi útil?

Pontuação 2

5 comentários:

In all honesty I wouldn't even know where to start. Shall I look for continuity on specific spots or....?

por

Do you have a multimeter?

por

Yes i do. :)

por


Any other ideas?


I'm open to test anytjing you suggest ;)

por

Hi @alextc

Warning!

If you are not familiar with electronics, do not attempt to repair!

You could suffer a fatal electrical shock! Instead, contact your nearest service center!

por

Adicionar um comentário

That large cap in the center bottom looks like it might be expanding. Hard to tell from the top view. If that top is looking convex, replace it.

There is schematics available here. Of course, they won't do you much good if you can't read them.

Is the battery charging when plugged in?

If it is running on battery, then the DC to AC converter is operating.

If it is charging the battery, then the primary AC is working.

If it does not run on AC, then what changes the relays or the relays themselves isn't working.

Update (02/18/2023)

I used a charger from Aliexpress.com. There are similar ones at Harbor Freight or Amazon. It automatically detects the type battery and charges it. I think about $20 to $40. It can be used on any type wet battery. A few can also be used on LiPo types.

Update (02/23/2023)

@alextc to the right of D18

Block Image

Esta resposta foi útil?

Pontuação 1

4 comentários:

Thanks for the input Bill. The link seems dead. Anyhow someone linked the schematics of the circuits before. To me they're just a hint but not something I'm used to read, definetly.

Yes, it runs on batteries and I'd say no, they're not being charged since the AC in is not reaching "somewhere". I could trace AC in until the main board, but unsure of the next step.

Let me check the large cap you mention and perhaps share better pics of it.

Thanks.

por

Sorry bout the link. I should have tested it or read it. It is obviously not right.

por

So R2 test are these 2 points?

https://imgur.com/YxmMvmZ

por

No, U are looking for the line sense signal, not trying to read the value of R2.

The bottom terminal of R2 to ground.

por

Adicionar um comentário

Hi Alex,

Okay, I read through the blog post you found where it seems to describe the same problem you're having and the guy's solution of replacing three capacitors. I've circled the ones that "vasvir" replaced.

Block Image

From left to right they're numbered C41, C40 and C3. Ultimately, the correct way to test a capacitor is with a capacitance, or LC meter. Since very few of us have those in our toolboxes, you can do a rough go/no go test with an ohmmeter. Capacitors pass AC current and block DC current, so to an ohmmeter (which uses DC current) it looks like an open circuit.

So you'll set your meter probes on the two contacts on either side of the capacitor and see if you have continuity. If there's no continuity, you're probably okay. If there is continuity, that doesn't necessarily mean the capacitor is bad, because there could be other connections in the circuit that the ohmmeter is testing instead of just the capacitor. So if you get continuity, the only way to verify whether the capacitor is bad is to remove it from the circuit; for C41 you can unsolder one of the legs and leave it dangling in space while you test it. The others are surface mount and will be difficult to remove just one leg; you can try, but you'll probably end up having to remove it completely from the board to test it.

On the other hand, those parts are really cheap; you'll generally pay far more for shipping than you will for the parts themselves. If you're going to go to the trouble of unsoldering C40 and C3, you might as well have replacements on hand and just put new ones in anyway.

For all three vasvir used 50V 22 uF capacitors, which is fine, although the ones already on the board are only 16V 22 uF. General rule is you can pretty much always safely go up in voltage rating, but never go down. So anything you find that's 16V or higher will work, as long as the capacitance is 22 uF.

You can start out looking on places like Digi-Key or Mouser Electronics; those two are pretty much guaranteed to have exactly what you need, but you may find it easier to find them on eBay or Amazon.

For C41 you can use pretty much any physical size of electrolytic capacitor; with through-hole caps you just bend the wires to go through the holes in the circuit board, solder it in and you're done. If you want to get as close as possible to the original, measure the height and diameter and search for ones of that size.

For the other two you'll need to fit the existing footprint on the circuit board. I'm pretty sure you'll find that they're a standard size; again, measure the height and diameter and search for SMT versions of the value you're looking for. Ideally you could measure the footprint for the unused C4 capacitor right near the top of C41; the data sheet will tell you the exact dimensions of the part you're looking at; just match it up with the two solder pads that are there for C4.

So yeah, that pretty much describes how vasvir fixed the same problem you're looking at, so I'd say it's worth a try.

Good luck, and keep up on the updates!

P.S., If you do replace the capacitors make sure you get the polarity correct. With electrolytic caps, unlike others like tantalium, it matters which way they're connected in the circuit. Note where the white stripe on the side of C41 is and make sure your replacement goes in the same way. For C40 and C3, the black spot on the top has to go in the same orientation it was originally in. Fortunately you've got pictures to refer to, so no worries about forgetting which way they go.

Esta resposta foi útil?

Pontuação 1

3 comentários:

Hi @dadibrokeit,

If the capacitor has a large enough capacitance when you connect an Ohmmeter to it you may get a reading as the capacitor charges (from the battery in the Ohmmeter) and if you reverse the meter leads another reading as the capacitor discharges through the meter.

With analogue Ohmmeters you can see the meter needle kick in both directions, one way when charging and then the other way when discharging

This doesn't tell you if the capacitor is OK or not only that it isn't open circuit.

por

Thanks so much for the detailed insight @dadibrokeit and for the additional tips @jayeff --- I'll go and test roughly the 3 capacitors mentioned before start trying to replace these.

OOC do capcitors die just after a few years of... not being used? They do apparently look right physically and the unit was working before getting stored... oh well!!

Someone also commented on the relays, any quick test I could perform on those?

por

@alextc

re capacitors here's a link that might explain a few things.

re relays - check that the relay coil has continuity but remember if the relay is still connected you may get a false reading due to possible parallel paths around the relay.

If you remove the relay it can be tested and somtimes can be operated with a small voltage supply (check relay specs on relay) good enough to then use an Ohmmeter across the relay contacts to see if the relay contacts make or break when the relay is operated if you can't see them physically move, although in the case of make contacts, they may physically make contact with each other but they may not "electrically" make due to dirty contacts or with break contacts they may be permanently made due to arcing across the contact which has welded them together so testing with a meter is advisable

por

Adicionar um comentário

OK next update, for whatever reason I measured the output while the unit is plugged into the wall and the unit is ON, aka, running from batteries... The results are... well... HILARIOUS?!

Block Image

Also measured R2 and it reads 0, given I placed the probes correctly :?

Esta resposta foi útil?

Pontuação 0

3 comentários:

Surge outlets are connected directly to AC thru MOVs. That is normal voltage with an AC input.

163V on the other outlets is obviously not right.

Please be specific about what/how U measured R2. The side away from the diodes (designated 2 on schematic) should be at a logic high 3-5V.

U may have more than 1 problem, or the processor is confused by its inputs or defective, or the inputs are wrong. ==> R2=line sense.

por

OK I'll recheck R2 properly... and report back. I'm assuming APC has no propietary battery modules RIGHT? I'm using Salicru branded which is another well known UPS maker and has same form factor/specs to my knowledge.

por

any battery of the right physical size and voltage will work. Some will even be higher AH, but that may also be specmanship.. APC batteries are much pricier, but may last longer.

por

Adicionar um comentário

So not sure if these make any sense?

https://www.dropbox.com/s/o6fv38y2pibnba...

https://www.dropbox.com/s/3h09fokz8rhg83...

@ruggb

Esta resposta foi útil?

Pontuação 0

9 comentários:

I can verify that neither make any sense.

You want to know the voltage on R2 pin 2 ref to digital ground.

Pin 5 of IC 8 is @ digital ground - so measure the voltage from the bottom of R2 to IC8 pin 5, which is the bottom left pin next to R85 marking.

R2 pin 2 is next to the C37 marking.

por

@ruggb Gotcha. Will report back. I was using the OPPOSITE R2 pin for measurements doh

por

Ooooook, getting 5.9v with the unit plugged to the wall, either turned on or off.

Better now? Hehe

por

That feeds pin 7 of IC7. 5.9V is TOO MUCH. IC7 runs on 5V. Time to start measuring IC7 voltages.

1st - verify that 5.9V is present on IC7 7. Then measure the 5V supply on pin 21 or C36. If it is over 5.5V, IC7 may be damaged. If it is high, then you must first find out why and fix it. Unfortunately, I can't find the source of 5VS. Page 4 of schematic indicates a 24V, 12V and 5V circuit, but there is no 5VS there.

por

"verify that 5.9V is present on IC7 7" - ok verify how?

"measure the 5V supply on pin 21 or C36" - mind if i ask where to set the probes?

I may not be using the most exact multimeter on earth so may be we are in a tolerance % both on multimeter and IC7 :??

por

Exibir mais 4 comentários

Adicionar um comentário

Adicionar a sua resposta

alextc será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 2

Últimos 7 dias: 14

Últimos 30 dias: 75

Duração total: 1,301