Ir para o conteúdo principal

The March 2015 update of Apple's 13" MacBook Air features fifth generation Intel Core i5 and i7 processors, resulting in slightly increased performance and battery life.

612 Perguntas Visualizar todos

2015 MacBook Air not turning on, orange MagSafe w/o battery

This seems like a strange issue. I went to turn on my computer after a full shutdown and it wouldn't tun on. I thought that the battery had drained even though I fully charged it the day before but that didn't work either. The MagSafe light went from green to orange, then eventually back to green but attempting to start the computer up didn't work. I tried dismantling the computer and removing the battery but the MagSafe light went from green to orange even with no battery installed and still won't start up. Even using the test pads to turn on the computer didn't work. I plug in the MagSafe cord and I see the fans jiggle for half a second before turning right back off. I tried swapping batteries with another Mac I have lying around but that didn't work either. Unplugging the keyboard also didn't work either. Also, doing the standard SMC/PRAM resets didn't work either. Even unplugging the battery and holding down power for 10 seconds then connecting everything back didn't help at all. Is my logic board screwed or is there something else I missed?

Also, there is no water damage and was previously functional.

Block Image

Respondido! Ver a resposta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário

1 resposta

Solução escolhida

Lets see if a deep SMC reset gets you going. Again disconnect the battery, but this time with nothing plugged in, press and hold the power button for a good 15sec's. Then plug in the MagSafe charger, your system should spontaneously startup.

If it does, let it fully boot up, then shut it down properly. Then plug the battery back in and now restart but hold the D key to enter into diagnostics. Let us know if you get any error codes.

Reference: Mac startup key combinations

If you don't get any errors, download and install this gem of an app! CoconutBattery take a snapshot of the apps main window and post it here for us to see Adicionar imagens a uma pergunta já existente so we can see what's happening with the power logic.

If resetting fails to change anything check your MagSafe charger and the port connection for dirt or corrosion.

Esta resposta foi útil?

Pontuação 1

4 comentários:

I tried this already but there was no fan spin and the MagSafe LED does the same thing. Oddly enough when I was messing about doing that caused the fan to spin for half a second before turning back off. Eventually, I was able to get the system to turn on without a battery but with the same light situation. Putting the battery back and my computer was able to boot up like normal. I'm not sure if it was me pressing the power button that caused it to not turn on or what but it's working now. Is there anything that I can do that can prevent this from happening again?


@jimmysofat6864 - Did you run diagnostics? Also lets get a CoconutBattery snapshot so we can check the power system.


@danj I ran diagnostics after and it reported no problems with code ADP000. And coconut battery appears just fine. Would like to note that my battery has an aftermarket battery. The photos were added to this post.


@jimmysofat6864 - I don't see anything amiss. Lets see where things are in a week.


Adicionar um comentário

Adicionar a sua resposta

jimmysofat6864 será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 0

Duração total: 98