Ir para o conteúdo principal

1.86GHz or 2.13GHz Processor, 128GB or 256GB Flash Storage

147 Perguntas Visualizar todos

TS0P sensor failure - fans stuck at max speed but trackpad works fine

Replaced the SSD in this system and been using it for a couple of weeks with no issue but now fans spin at full speed and laptop is very slow!

Running Apple Hardware test I get this error: 4SNS/C0000008:Ts0P--124

After a little investigation I found this is a sensor found in the trackpad so I replaced the trackpad and trackpad flex cable with a known working one, however the system still runs at max fan speed and displays this error.

Have also tried PRAM and SMC reset and nothing happens!

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
2 comentários

Did you install an OEM Apple SSD from that same model? Or a 3rd party model? I know the SSD has temperature sensor lines that talk to the SMC which may trigger issues like this in a non OEM SSD. But I would think that issue would have cropped up immediately and shouldn't be triggering that sensor in the trackpad....

Have you checked the trackpad connector on the board? I would pay particular attention to some of the pins towards the middle which are the lines that go to the SMC.

por

@flannelist Yes the SSD I installed was an OEM. I’ll have a look at the trackpad connector but I know the device hasn’t experienced any water damage.

por

Adicionar um comentário

2 respostas

Pergunta mais útil

Well the error Ts0P is the top case error as you can see here directly from the Apple service manual

Block Image

The sensor its self sits on the trackpad so you don’t need to go to Apples extreme of replacing the whole top case, just replace the trackpad. If that fails to solve the problem then you have a deeper problem within the logiboards SMC Logic on the back side often damaged by a spill

Block Image

Esta resposta foi útil?

Pontuação 1

1 comentário:

Thanks! Replaced the trackpad and and trackpad flex cable and nothing changed. I'll take a closer look at the logic board.

por

Adicionar um comentário

@toumbi Ts0P could be:

Trackpad

Trackpad Flex

Camera (in some models)

Trackpad flex connector (logic board)

Since you already replaced the trackpad and the and the trackpad cable but ( on some models) there is a relationship between this sensor and the camera, try powering it up without the camera connected and see if that makes a difference. After that you need to check around the logic board connector and will have to do a deep dive onto the components related to the trackpad. For that you require the boardview as well as a multimeter etc.

Esta resposta foi útil?

Pontuação 1

1 comentário:

Just powered it on with iSight camera cable disconnected and still fans at full speed :/ I'll have a closer look at the logic board.

por

Adicionar um comentário

Adicionar a sua resposta

Tom será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 9

Últimos 30 dias: 15

Duração total: 134