Ir para o conteúdo principal

Line of business laptops originally sold by IBM and then purchased by Lenovo in 2005. Older models (Pre-XX50) have a WiFi whitelist, so wireless card replacement is not as easy as buying a bulk generic card online.

577 Perguntas Visualizar todos

Lenovo L480 not booting but power LED is on

  • screen is blank, caps lock LED doesn’t light up
  • power LED and the red LED outside are on
  • holding down power button doesn’t do anything however the red LED blinks off and on every 7 seconds
  • when plugged in white charging indicator lights up
  • holding down power button while plugged in, red LED flashes on 3 times every 5 seconds and then turns off
  • this model does not have a reset hole or removable battery

please advice

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 1
Adicionar um comentário

2 respostas

Pergunta mais útil

You may try turning on the PC using another outlet, changing the charger, doing a Hard reset and checking the RAM.

Otherwise check out more methods provided in the post below.

If none of these worked, it's probably the motherboard.

Esta resposta foi útil?

Pontuação 1

1 comentário:

Worked an absolute treat.. Initially chuffed.. but on checking battery I'm informed " No battery present ". Do I need to get back in & check both connection ports are firmly installed ? Also informing me " Power mode ( plugged in ) . Better performance "


Adicionar um comentário

Hi @g0f0ndwyxr ,

Try a full power refresh and check if this resolves the problem.

Here’s the procedure:

Disconnect the charger if connected and turn off the laptop.

Dis-assemble the laptop and disconnect the main battery from the motherboard. You only have to disconnect it, not remove it.

Disconnect the coin cell RTC battery from the motherboard.
Here’s the hardware maintenance manual for the laptop. Go to bottom of p.75 & then to p.77 to view the necessary pre-requisite steps and then the procedure for how to access and disconnect both of the batteries.

Press and hold the laptop’s Power button for a full 30 seconds to dissipate any residual charge from the motherboard. This will reset the BIOS which may have become corrupted preventing a normal start.

Reconnect the coin cell battery and the main battery.

Re-assemble the laptop and connect the charger.

Try to turn on the laptop and check what happens.

Esta resposta foi útil?

Pontuação 1

4 comentários:

I can't do that the laptop is company property. I knew working from home was a mistake.


@g0f0ndwyxr Well the laptop will break even in the office, do not blame WFH.


@thesimpleguy and I could have had a replacement in a day


Sir mine also same problem.... please i want to connect with u


Adicionar um comentário

Adicionar a sua resposta

juliana restrepo será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 9

Últimos 7 dias: 68

Últimos 30 dias: 279

Duração total: 13,452