Ir para o conteúdo principal

Repair information for the Sony Bravia 42" LCD TV. Released in 2012. Model number: KDL42EX440.

22 Perguntas Visualizar todos

Sony Bravia TV turns off repeatedly.

My Sony Bravia TV (model number KDL-46W905A) turns off randomly every few minutes. At first it seemed that it only happened when it was directly plugged into the wall, but not when it was plugged into an extension cord, but now it happens no matter what. It always turns back on after a couple of seconds, and is otherwise working perfectly, but something seems to be tripping and turning it off, with no apparent pattern. I am new to fixing stuff but really don’t want to have to throw away an otherwise perfectly good television that my landlord was going to throw out! Thanks to anyone who can offer any advice!

Respondido! Ver a resposta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 1
Adicionar um comentário

2 respostas

Solução escolhida

Hi @pbddn,

When it switches off, does it go back into standby mode and you have to turn it on or does it restart by itself?

If it goes back to standby and stays there until you turn it on again, then it sounds as if something is overheating and it is shutting down.

If it restarts by itself it could be a loose connection (dry solder joint?) or a voltage problem perhaps

Here’s the relevant troubleshooting flowchart from the service manual which may be a good place to start. (see p.26 also)

Update (05/25/21)

@pbddn

I don't know.

It may also be software related.

Just to eliminate any possibly corrupted software, try a power refresh to hopefully restore any corrupted software.

Turn off the TV if on and disconnect the power from the TV.

Press and hold the TV Power on button for a full 30 seconds and then release it.

Reconnect the power to the TV and turn it on and check.

Not hopeful about this but still worth a shot as it doesn't take long ;-)

If still no good try to update the firmware

My thinking on this is that it seems with your TV that it looks for the file on the USB port soon after it starts and obviously since most times it is not there it progresses through the startup sequence of the software already installed.

If it does recognize the USB and stays on and gives onscreen instructions etc to load as described in the firmware instructions I linked then it may be that the firmware already there has a problem and hopefully this will fix it.

The caveat is that if the TV already has this firmware version installed usually it may not re-install the same version again. A lot only "update" to a later version if you get what I mean.

If it fails to recognize the USB etc then looking at the manual (see p.33) it may require software diagnosis to check if some things are working or not so I don't know.

Sorry I can't be of more help.

Esta resposta foi útil?

Pontuação 3

5 comentários:

Thanks so much for responding @jayeff !

It restarts by itself, so perhaps it is a loose connection. I disconnected the power cable yesterday and then re-attached it and now the problem is much worse - it only turns on for a few seconds before turning off and coming back on and turning off again after another second or so etc.

Do you think this could be as simple as a replacement power cable or is it more likely to be a connection on the board I am connecting the power to?

por

@jayeff Thanks! Holding power button for 30 seconds while the TV is off and then turning it on again worked ?. You really are a winning person for sure

por

Thank you mine did the same thing.its only few moths old. I pressed the power button until i saw SONY on the TV about 30 seconds on the remote and it reset the TV and works fine now but today few min to have sound again. It worked

por

@jayeff. I have a Prometheus 65in TV 📺 that had the same turning on and off problem. Holding this power button for 30sec worked, thank you. You saved my day as my manufacturer had asked a repair fee that was more than the amount i bought the set . by Ruka in Japan 🗾

por

I had the same issue with a Bravia 55x950H. I read a different forum thread that said to unplug it from any surge protectors, etc and plug directly into wall outlet. Worked for me. I’ll probably try a different surge protector to see if maybe it’s the new Anker I bought or if it happens with others too.

por

Adicionar um comentário

It needs a software updaye I has the same problem

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Pete Budden será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 42

Últimos 7 dias: 383

Últimos 30 dias: 1,836

Duração total: 29,660