Ir para o conteúdo principal

Conserte seus objetos

Direito de executar reparos

Loja

Late 2011 model, A1278 / 2.4 GHz i5 or 2.8 GHz i7 processor.

638 Perguntas Visualizar todos

Issue with machine not accepting new SSD

Hello,

Weird one this hope some one can help.

I’ve got an old 2011 13” MacBook Pro had the screen repaired but the hd wouldn’t boot, replaced the SATA cable and the HDD boots, did clean install all works fine.

Installed a SSD after initializing it via format as an external HD in disk utility. Preformed an internet recovery and started to install Lion (old) select the disk downloaded the OS then system reboots to start install only it doesn’t load in, at first I was getting the prohibited sign, so I tried a new tact by installing the OS on the SSD as an external device which worked and it was bootable, then when I put it back into the machine on boot I get the flashing folder icon and I cant boot in.

I swap the SSD over to my 17” MBP 2011 and it works fine no issues boots straight up.

Tried numerous processes of elimination by using my boot drive from my 17” MacBook Pro in the 13” MacBook Pro but I get the same issue - flashing folder. But a standard HDD works fine in the old machine.

Does anyone have any ideas?

Many thanks

Dean

Update (02/09/2021)

Hi Nick,

I did replace the SATA cable prior to installing the SSD with this cable, https://www.amazon.co.uk/gp/product/B07B...

I will buy a new one maybe from OWC and try again, the image below is the cable thats currently in the machine.

Block Image

Its perplexing as when in disk utility it recognizes the SSD When installing via external SSD and disk utility it works and boot. As soon as its in the machine, flashing folder on boot, holding alt only takes me to recovery.

Responder a esta pergunta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0

Comentários:

@huntercosta Did you hard bend the cable? That tends to damage them.

por

Adicionar um comentário

2 respostas

I think you can easily fix this. With the SSD in your system, restart your system and press the Option (⌥) key to enter into the Startup Manager. Select your SSD from the menu your system should startup! Now we need to do one more thing as your SSD is not blessed as the startup drive, You need to go to your Systems Preferences, open Startup Disk and alter it to your SSD. That should fix things.

Reference: Mac startup key combinations

Esta resposta foi útil?

Pontuação 0

Comentários:

Ello mate, thanks for your reply. Unfortunately it doesn't seem to work! I hold down the alt key to select the boot disk but it takes e to internet recovery. Really frustrating

por

@huntercosta - Sounds like you are not using the systems keyboard or have a bad key. Try the other side key. Any luck?

por

Just removed the SSD and placed in an enclosure, plugged in the old HDD and tried to select the Startup disk by pressing alt on boot but it only shows the one HD that is the installed HDD, If i take this SSD and put it into my other MPB it boots straigh into it, Any clues on what else might be the issue?

por

Could it still be the SATA cable?

por

@huntercosta - You didn't install the OS cleanly on the SSD drive. Reformat it to GUID with a journaled file system and then run the OS installer again. You may ant to get a fresh installer from here How to get old versions of macOS. Just keep in mind the older image file you may have may not work If you've got an old macOS installer image, it will probably stop working today

I find setting up a USB Thumb drive as an OS installer is helpful here's how How to create a bootable macOS Sierra installer drive I do recommend sticking with macOS Sierra as the highest version for SATA based systems.

Your 17" MacBook Pro may not support the faster SATA III (6.0 Gb/s) SSD and yes! You may need a new HD SATA cable as the original cable was only rated for the slower SATA II (3.0 Gb/s) drives Apple was using at the time. Apple also had an issue with the cables wearing out as well Your Hard Drive Cable Is A Ticking Time Bomb

por

Mostrar mais 8 comentários

Adicionar um comentário

The issue you’re having on the 2012 is usually due to the SATA II HD cable issue in these, or flat out cable wear. The issue with these original cables is the wear tends to be invisible, so you never know it until you put an SSD in - which is why it’s better to change the cable yourself when you get the computer. You also need to protect it, because the aluminum milling wears out the cables as they move inside the chassis. The issue is so common when I got my 2012 13” I proactively replaced the cable so I knew it was done.

Refer to this photo from my old 2011 (bad board and the LVDS cable fell apart when I took a look at it to see if I could fix it, so I replaced it):

Block Image

The Kapton tape is extra, so it’s optional. I did it at the time because I felt it was needed, but did not carry it to my 2012.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Dean Gatenby será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 5

Duração total: 47