Ir para o conteúdo principal

Repair guides and support for the 27" Dell UltraSharp U2711 external display released in February 2010.

7 Perguntas Visualizar todos

Blocky image at forced 1440p resolution

Hi folks,

I was wondering whether anyone has come across this problem with the U2711:

After a move (the culprit), I cannot set the resolution to the maximum 1440p any more. Most Windows PCs will strangely default to a 16:10 1680x… resolution. If I force it to 1440p via the graphics card, then the image is all blocky.

Currently, I’m using the display as a “TV” on a Linux machine and I was able to coerce at 1080p signal out of it. There are vsync issues with it though. Very odd.

The on-screen menu is sharp though.

Obviously, this is damage is somehow from the move. Maybe temperature fluctuations and condensation caused it? Beats me. I’m hoping someone else came across it and had luck with fixing it. It’s a nice panel after all.

Thanks a bunch, fixers!

Best,

Mike

PS: I forgot: tried various cables and pretty much all ports on the screen. All the same.

Update (12/07/2020)

Luckily enough, when I tried to connect the screen via display port again, it now shows 1440p resolution. Sweet, no need to open up the monstrosity.

Respondido! Ver a resposta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
2 comentários

Hi Mike,

It would be helpful if you posted your update as an Answer otherwise it is listed as unanswered. Ta.

por

@aactech Ah, yes I'll do that. :)

por

Adicionar um comentário

1 resposta

Solução escolhida

When I tried to connect the screen via display port again, it now shows 1440p resolution.

Not quite a “repair answer”, but maybe helpful for someone else with the same problem.

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

Adicionar a sua resposta

Mike será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 0

Duração total: 142