Ir para o conteúdo principal

Conserte seus objetos

Direito de executar reparos

Loja

Announced on October 16, 2014, identifiable by the model number A1347 and EMC 2840.

179 Perguntas Visualizar todos

No Sound After Upgrading Mac Mini Late 2014's Hard Drive

I followed and completed Sam Goldheart ’s Mac mini Late 2014 Hard Drive Replacement guide < Mac mini Late 2014 Hard Drive Replacement > and ran into a problem when I turned the computer on - no sound. Despite no sound, the computer starts up fast and the applications run much faster than before.

I checked the Sound in System Preferences and the Output was set correctly to Internal Speakers. Also, mute is NOT checked.

I did the PRAM and SMC reset and used Apple Diagnostics to see if there were any issues with any of the components inside the computer - there were none.

The OS is updated to Catalina.

And lastly, I replaced the original hard drive with a Western Digital 500GB WD Blue 3D NAND Internal PC SSD which Amazon says is Mac compatible.

I took the computer apart and went through the steps a second time and still got the same results of no sound. Is it possible that I missed connecting a cable or perhaps damaged a component?

Thanks!

Respondido! View the answer Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0
Adicionar um comentário

The Essential Toolkit

The most helpful tools in our most compact kit.

Comprar agora

The Essential Toolkit

The most helpful tools in our most compact kit.

Comprar agora

1 Resposta

Solução escolhida

Let’s check the speaker its self refer to this guide Mac mini Late 2014 Speaker Replacement checkout Steps 26 thru 28 did you knock the connection or puncture the speaker diaphragm?

Update (10/02/2020)

I’m starting to think your issue is within the headphone jacks switch within the jack has failed.

Block Image

I also think you just didn’t notice it as you where using an external speaker set.

What can happen is the connection of the headphones will cause the internal speaker to be disconnected from the circuit. Which can explain why you get no sound playing music or what ever from the internal speaker.

As far as the Bong sound that can be reactivated once you have gotten the internal speaker working by altering the setting How to turn your Mac startup chime back on

As for why your headphones work and your speakers aren’t that gets into the plug not having the correct contact alignment or shape. Or, just a bad cable. You proved the signal is getting to the jack with the headphones so we do know the jack is working part way! As the jack is part of the logic board you can’t replace it but you might be able to look in through the hole to locate the switch contacts and make sure they are not messed up or just dirty.

Esta resposta foi útil?

Pontuação 2

Comentários:

Hi Dan,

I'm afraid that your suggestion sadly did not pan out. I took a look at the speaker and its connection and it appears to not be damaged and the connection looked good. After I put the computer back together, I plugged it back in and turned it on. There's still no start up chime or any other audio coming from the computer.

Could it be another connections deeper in the computer?

por

@meatanpotatoes - OK, lets try one more thing. Plug in a head set or speakers into your headphone jack see if they work playing some music or podcast.

por

Hi Dan,

I plugged in the headphones in at start up and there was still no chime but there was sound when I played a YouTube video on Safari. The same could not be said for any sound coming from the speaker jack.

por

@meatanpotatoes - I'm confused here ??

The headphones played music but so did the speaker? Please restate what works and what doesn't.

Are you only having an issue with the startup Bong not being present when you start your system? Apple disabled it in one of the OS releases I don't remember which right now, There is a way to re-enable it if you want it.

por

No bong/chime at start up with or with out headphones plugged in. There was a chime at start up before I swapped out the old hard drive for the cloned SSD. Both drives have Catalina on them.

Once the computer was running, sound did come out of the headphone jack when I plugged in my headphones and played videos from YouTube.

No sound came out of the speaker jack when I plugged in my speakers.

por

Mostrar mais 13 comentários

Adicionar um comentário

Adicionar a sua resposta

Stuart Wexler será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 2

Últimos 7 dias: 5

Últimos 30 dias: 15

Duração total: 118