Lenovo Helix 1 - Primary Battery not communicating or charging.

Ignore the Yoga reference as the Helix is not listed on this site.

I have a Helix 1st Generation. I have obtained a genuine Lenovo battery to replace the primary battery in the tablet part. The keyboard battery is fine. The original battery is ok but only holding 2/3rds charge after 6 years. The new battery is recognised by Windows 10 as 0% and the Lenovo Diagnostics tool sees it but cannot communicate with it. This is the second battery it has not recognised. I have uninstalled the AC and battery drivers to no effect. I have checked the connections.

Any ideas?

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0

10 comentários:

Hi @gordonhelix ,

Does the laptop work when on the battery only?

I know that you said that it shows 0% but was wondering if it had a bit of a charge in it whether it does work this way.

I don't know the laptop but looking at the user guide there is a disable built in battery option in the BIOS > Config Menu > Power settings. It does say that the setting will re-enabled when the AC adapter is reconnected after the setting has been disabled but was thinking that it still might be worth a check or perhaps if the BIOS was reset to default values in case any were corrupted for any reason.


Hi, jayeff,

Thanks for your response. I tried separating the tablet from the powered keyboard and it went straight to hibernate/lockdown, suggesting no power. I reset BIOS to default values. I was aware that the primary battery had to be disconnected before replacement. The laptop woks fine on the original battery, which only has 2/3 capacity due to 6 years of use. This is the second replacement Lenovo branded battery I have tried, with different serial numbers, from the same supplier. It doesn't look like a fake when compared to the original. I have tried uninstalling the battery drivers to no effect. I get no messages that the batteries are not genuine. I have used the Lenovo Diagnostics tool and it tells me of a failure to communicate and wonders if the battery is unplugged. I have checked the connection to the motherboard and it seats the same as with the working original battery.

Any thoughts?


The original replacement battery had a small amount of charge that lasted 30 minutes. Otherwise the symptoms were the same.


Hi @gordonhelix

Have the replacement batteries got the same "part number" on them as the original?

Here are two links showing the battery part numbers.

As I said I don't know the laptop so I linked what I found

Helix (Type 3xxx)

Helix (Type 20CG)

Click on Select Commodity > Rechargeable batteries and Internals.

Apologies if they are the same and if this is what you did when ordering


Don't apologise, we often overlook the obvious. The part numbers do match up.

I could understand a possible BIOS/driver issue if all the primary batteries did not work. However, the original battery works fine. I uninstalled the Microsoft AC and battery drivers in Device Manager and re-started. No joy.

In Device Manager, under System Devices, I can see Lenovo PM Device and Lenovo Power Manager. I did not want to uninstall those in case it screwed things up.

Any thoughts?


Exibir mais 5 comentários

Adicionar um comentário