Surface Pro 4 Won't turn on

Hello,


I have a surface pro 4 that I bought from someone 4 months ago. It was out of warranty so I can't go to microsoft as they've only suggested an upgraded replacement for 50k inr (around 700$)


I have been facing the issue of fast battery drain on it. I don't know if it was battery issue or it is just a problem with these devices, because I see a lot of people had questions regarding this. Even when I kept the surface completely shut down, a fully charged battery got drained in just 3 days without even starting the surface.

I have the need to use it only when I am going out because I work from home on my PC. So after a few weeks of not touching the surface I tried to start it yesterday, when I pressed the power button nothing happened. I thought the battery is drained just like before so connected it to the charger (I only use the original charger)


The charging port has a solid white light that is ON at all times when I connect it to the surface. But even after hours of charge the device is not starting at all. Microsoft team suggested me some basic troubleshooting like pressing the power button for 15-20 seconds, pressing VolumeUp+Power button, but it didn't work. I also tried the CPR method that has worked for some before.

The main question I have here is this, does a Surface Pro 4 work on direct power if the battery has malfunctioned ? Because in that case this does not seem to be a battery issue. Because the device is not starting even while charging. If there is a chance the battery is dead (Considering the fast drain in the past months) then I have no choice but to replace the battery myself (I know the risks but have no other choice)

Responder a esta pergunta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 1

Comentários:

I have been in the same situation since school started. I haven't gotten into the lab yet to see if my battery is faulty, as I did a battery and screen replacement. I agree with you that it does not make sense that these SP4 will not power on when plugged in. My SP4 worked before my attempted repair, so I might have fried the motherboard, but it could also be a cheap battery that will not charge. Either way, I hope you find a solution to your issue because I'm sure many others are facing this no power issue.

por

Adicionar um comentário