Ir para o conteúdo principal

Second generation Learning Thermostat from Nest Laboratories

20 Perguntas Visualizar todos

nest won't connect to the heatlink

Hi Folks, my nest wouldn’t connect to the heatlink. I’d been on to nest support and they said the system needs to be replaced. Apart from checking version numbers there was no “nest magic” suggested by the support rep, over and above what I’d already tried.

Respondido! Ver a resposta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 5
9 comentários

Thanks @oldturkey03 great guidance, I've done as you recommended. All the best - Jim.


@jimcraiguk Awesome! Great job, thanks.


I was on technical support for half an hour with the Heat link unable to pair with the Thermostat (gen3), went through all the usual hoops, but the only solution was (after upgrading the software with software upgrade function of the thermostat) was a complete reset of both and NOT connecting to the WiFi and NOT setting up the app. Just skip those steps and it'll able to pair with the Heat link. You can connect to the WiFi and app after that.


I had same issue w/ new Nest 3 + Heatlink. Tried everything and all I got was "blue pulse" on heatlink and h71error on thermostat after many minutes trying to connect wirelessly. Finally got with knowledgeable Nest tech. What worked for us was to connect the thermostat with the T1, T2 wires directly to heating unit. This allowed the thermostat to fully "install" w/o wireless connection. Once installed, I selected and performed a factory reset of the thermostat. On the reset reboot, the thermostat connected BOTH with wires and wirelessly! Then just disconnect the T1, T2 wires and all is well for me. Only trying to connect wirelessly prevent the thermostat from fully setting itself up and was not able to select a full factory reset which then resolved my issue. Frustrating? yes, and instructions should suggest to try a wireless connection first if all else fails. (I brought the thermostat close to the heatlink to use about a 3' piece of T1/T2 wire; and micro usb to power the thermostat). Good luck.


Had the same problem the only solution is what DandM Dame suggested. Pretty easy. Isoloate the power to the boiler and Heatlink device. Take off cover and connect two cables on T1 and T2 Terminals. Then connect to the nest themostate. Then do a factory reset, I also had to re-enter the pairing code from the Heatlink. Really what a faff.


Exibir mais 4 comentários

Adicionar um comentário

3 respostas

Solução escolhida

Searching the web I came across an article that included how to re-boot the thermostat. The nest techie didn’t suggest this. I gave it a try and it’s all working again. You can’t beat a good old “switch it off, switch it on” can you?

The reboot is achieved by pushing the display in for about 20 seconds. Apologies if you know this already.



Esta resposta foi útil?

Pontuação 4

4 comentários:

I didn't know that. My nest wouldn't connect to the heatlink so I pushed the nest display for about 10 secs, the nest turned off and turned on again. A quick reset of the date and it was sorted! Thanks Jim.!


Thanks - worked for me when nothing else would!


Omg thanks so much random people on the internet. The troubleshooter didn’t help but as you say doing a ten sec restart on the actual nest did!! Thank you!!


Worked for me after all else failed



Adicionar um comentário

Thanks to those who posed here (DandM Dame and mas.sheraton) I have managed to get my Nest 3rd Gen working.

My problem:- failure to establish connection between heatlink and thermostat (H72 error). This persisted despite many reboots, units being next to each other etc.

Solution : Use the wired setup, connecting T1 and T2 of heatlink and thermostat) and completed the setup steps without a wireless connection. This allowed access to main menu and the factory reset option. Started working immediately for me after this, would recommend you also do a heatlink reset (hold button for 15 sec) just before factory reset on the thermostat.

Esta resposta foi útil?

Pontuação 1

2 comentários:

Hi Adrian

I have exact same issue but mine is already hard wired and no connection between thermostat and heat link. Tried both resetting options on heat link and still not working (ie: no lights on heat link). Tested voltage on heat link and getting 230v. Plugged in USB cable and heat link turns on.

Have plugged in USB cable to thermostat and reattached to wall mounted base. Thought he I was getting somewhere running through setup process but when trying to connect to heat link it fails. I’ve no idea if the fault is the heat link, thermostat or both. Driving me crazy!


Hi Paul,

We've had this issue twice with our nest, the first time it was the heatlink (n72 code I believe), if you call Google they will send you a new one. Then we had the issue again last week. Google sent another heatlink to us, but I had also had to replace the cable to the socket as that turned out dodgy as well. Hope this helps.


Adicionar um comentário

Usually there is a long troubleshooting section available inside owner’s manual for Nest tstats. You can find your model here. You should see some error code if it can’t connect. To understand the message just open the manual on troubleshooting page. The reason usually very simple: some wire not connected.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Jim Craig será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 2

Últimos 7 dias: 44

Últimos 30 dias: 252

Duração total: 30,279