Echo 225 Trimmer won't start. Tried all the basics

Purchased a used Echo SRM 225 that won’t start for nothing. This is what I have done so far.

Put in a new carb, new air filter, new fuel line and filter and a new spark plug. Also new gasoline 50:1 mix

Checked the ignition coil and the new spark plug for spark. Also checked it with the ground disconnected.

Disconnected the off/on switch to make sure it’s not that.

I have not checked the compression but have a new piston ring and cylinder gasket that I have not gotten around to changing out. I do smell gas from cylinder when trying to start but have not checked the inside of the cylinder for scarring. I did check the piston by removing the muffler and the piston appears to look fine with no scarring.

I will also be cleaning the spark arrestor when putting on the new piston ring.

I’ve worked on quite a few different trimmers with success but this one has got me stumped. I’m running out of options and do not want to put any more money into this.

Any other suggestions would be greatly appreciated!

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário