Ir para o conteúdo principal

Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

583 Perguntas Visualizar todos

Disabling the dGPU via software and hardware

Hello ,

I recently disabled a dGPU on a A1286 MBP because of the known ATI dGPU issues.  Sleep, wake, dim and bright screen functionality all worked great in macOS Sierra, however the 4 mentioned features do not work with High Sierra as documented through various posts on the internet.

One of the more detailed posts I came across was,

https://realmacmods.com/product/macbook-...

I had High Sierra installed on the machine, disabled the dGPU by blindly booting (LCD would not even properly function when booting into single user mode) into single user mode, and inputting a command to disable the dGPU without seeing anything on the screen.  Once I rebooted the box, the LCD was functioning as it should again.  That said, I bypassed the 1 ohm resistor (by desoldering it from the logic board and soldering a jumper wire so I could enable disable the connection at my leisure) to permanently disable the dGPU, and then attempted to restore sleep / wake , dim & bright functionality for high sierra, and after desoldering the 1 ohm resistor to disable the dGPU via hardware modification and booting the machine the screen / panel was still functioning.

That said, I proceeded to solder a jumper wire going from a SMD cap to a SMD resistor as described in the above posted link in hopes of reenabling the sleep, wake, dim & bright screen functionality for high sierra. And as far as I could tell sleep / wake functionality was working when closing and opening the lid of the MBP.  When i began to mash the dim and bright buttons on the keyboard that is when things started to glitch out on the screen, and eventually the LCD panel went dark.  I haven't been able to get the LCD to light up again ie. function as it should, but before I blew everything I enabled ssh on the box, and I can still ssh into the machine and everything (but the screen) appears to be working as it should.

Is there any way I can get the LCD working again, I'm assuming more than likely a component faulted out on the logic board due to how the LCD failed and because of my magnificent soldering job .  However I have NO idea where to even begin looking for a faulty component on the logic board much less a SMD resistor or cap.

Any thoughts or suggestions would greatly be suggested

cheers

Chris

Respondido! Ver a resposta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0

Comentários:

@arbaman [br]

[br]

It ended up being a backlight issue, thus why the computer was fully booting up, and i could ssh into it.

por

The backlight is not a critical circuit and as such it doesn't prevent the board to fully function even in its absence.

por

Adicionar um comentário

1 Resposta

Solução escolhida

The only advice I could give is to restart from step zero, remove the jumper you’ve done and reinstall the resistor in place to check if things get back to normal/faulty. It might be that something went wrong somewhere and the OS is back again trying to find the Gpu that is not there because of the missing resistor.

Esta resposta foi útil?

Pontuação 3
Adicionar um comentário

Adicionar a sua resposta

chrisrjones1983 será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 2

Últimos 30 dias: 8

Duração total: 184