Ir para o conteúdo principal

A1418 / EMC 3069 / 2017 / 3.0 GHz quad-core i5, 3.4 GHz quad-core i5 or 3.6 GHz quad-core i7 Processor. Released June 8, 2017.

125 Perguntas Visualizar todos

[HELP] Machine won't turn on after CPU upgrade.

Model - iMac 21.5 4k 2017 3.0Ghz i5

So I replaced the CPU with Intel i7-7700, I’m sure I followed the instructions carefully.

After putting everything back the machine won’t power on, only 1 LED on the logic board came up.

Tried a new power supply on, still doesn’t work.

Tried changing the CPU back to the original one, still didn’t work

I took it to diagnose at an Apple Authorized Service Provider and they told me that the power supply was non functional, used KGB PSU to test, and logic board did not respond.

Any solution for this? Would appreciate any kind of help. At this point I don’t mind using the old CPU, just want the machine to work again.

Respondido! Ver a resposta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0
Adicionar um comentário

4 respostas

Solução escolhida

It sounds like you damaged the logic board or the CPU housing. You should try to purchase a logic board with an i7 cpu and not upgrade.

Esta resposta foi útil?

Pontuação 1

Comentários:

Right, currently I'm looking for a new logic board to replace the damaged one...seems like there is no market for 2017 model. Is there any other possibilities?

por

Adicionar um comentário

Inspect the socket pins I’m suspecting you damaged a few (shorting)

Esta resposta foi útil?

Pontuação 1

Comentários:

Will do! If the pins are damaged, this means that I have to find a new logic board to replace correct?

por

It depends on how bad they are bent.

I won't candy coat it, likely needs a new one. Sorry ;-{

por

Thank you for the input!

por

Adicionar um comentário

The exact same thing happened to me last night. Only to find out after hours of rechecking everything that I forgot to plug in the tiny cable on the left side of the power board. It’s for the power switch. No wonder nothing happens when I press the button.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

When you replace the CPU or GPU or PCH, you need to rebuild the firmware and the PCH timing need to reset. Once you tried to boot up, the machine goes haywire because it doesn’t recognise the CPU. It got nothing to do with power supply or logic board.

There are very few people can build the firmware and according to Dan, Louis Rossmann may be able to rebuild it. I am not a celebrity so I only do the work for people who know me and trust me for what I do. If you are in California SF Bay Area, I can do it next day service but if you are from other part, you need to figure out a way to get it here.

Esta resposta foi útil?

Pontuação 0

Comentários:

Can I ask, I have replaced countless CPU’s on these machines without any issue. Now suddenly with 2 machines I get something similar, however with me the first 4 led’s light up, however no display and the last led won’t turn on. The machine starts, reboots when I push the alt-cmd-p-R keys etc. Swapped displays and the display is 100%. Any suggestions? Am mystified.

por

Fixed this. When disconnecting the LVDS cable clip with my fingernail, I inadvertently removed a tiny cap. Fixed. Stupid.

por

Adicionar um comentário

Adicionar a sua resposta

Wasin Rojanametin será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 10

Últimos 30 dias: 32

Duração total: 840