Ir para o conteúdo principal

[HELP] Acer Aspire ES1-521 will not turn on or charge

I have tried to upgrade my HDD to an SSD in my Acer Aspire ES1-521

To begin with I downloaded Macrium Reflect software on the Acer to clone the data on the HDD to the SSD. After this copy was made I then dismantled the laptop following this YouTube tutorial:

(NOTE: He does not disconnect the battery in this tutorial. Neither did I to completely replicate the instructions.)

As in the video, seeming simple enough, I put the SSD in the small metal frame and into the SATA port and plugged it in. I then replaced all of the screws, clicked the frame back in to place, excited to see the increased performance on my laptop. I flipped it over, opened it up, pressed the power button firmly. Nothing happens. I plug it in and the charging light does not come on. This left me worrying what did I do wrong. I then opened the casing back up to ensure I had correctly re-attached all of the ribbon cables, to no avail. To be 100% sure this wasn’t the issue, I disconnected all three (including the one the guy didn’t in the tutorial) and reconnected them. This didn’t fix the issue.

Since then I have tried a multitude of options such as holding the power button down for a duration with the battery disconnected, trying to boot with the charger plugged in and the battery disconnected, disconnecting everything removing the RAM and replacing it. All to no avail.

I only use the Laptop for work but having built the PC I am typing this on myself I felt that I was ‘savvy’ enough to replace this component, but I am really stumped as to what I have done wrong. Especially when following a tutorial.

To anyone reading this, Am I doing something glaringly obviously wrong? Is there anything else I can try? Should I bother taking it to be repaired or should I start looking for a new laptop?

Thanks for any of your time in replying or helping

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 1
Adicionar um comentário

3 respostas

Pergunta mais útil

You should have removed ALL power before starting - the AC adapter, the battery, any USB cables that are connected to anything that is powered, and any thing else that might be able to transmit power into the laptop.  If you don’t first remove all power, it is possible for something to get damaged electrically when you work on the laptop, including when you swap the hard drive.

I’m not saying that this is definitely the problem here, but it could be.

Likely there is no actual damage, but rather some bad data in a circuit somewhere in the computer.  Try removing all power, and then remove the CMOS battery for a few minutes.  Then replace the CMOS battery, then replace everything else you removed.  By doing all of this, you will clear all circuits, including the BIOS.  This may clear up the problem.

Esta resposta foi útil?

Pontuação 1

3 comentários:

Hi, Thanks for the quick reply!

I did disconnect everything but the battery. Speaking to a friend who works in computing (not sure how accurate this is) he said the voltage or current from the battery shouldn't be enough to fry the motherboard, hopefully, this is the case

I have not tried the CMOS battery method as of yet so I will try this next and let you know


Hi there,

Unless i'm looking at the wrong component, the CMOS battery is soldered to the board, I cannot remove it without breaking the solder


Sad to say, some laptops are made this way - a part which will eventually die and need replacement is permanently attached to the motherboard. There is no need for that, unless you want to force the customer to buy a new computer every five years.

There may be a jumper that you can remove, which will clear the CMOS memory. If so, then that will accomplish the same thing as removing all power including the CMOS battery.


Adicionar um comentário

I upgrade my acer aspire E1-531 laptop from windows 8.1 to windows 10. After that my battery was drained and it shut down without warning and the battery showing charging but is not increase the percent 58% if i remove the charger it shut down

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário


Even if your friend tells you the difference - the remaining voltage is surely strong enough to kill single components. Anyway it doesnt have to be such a big thing.

I would try to disconnect him from any power source - unplug the battery and wait for about 10 minutes. Maybe this works for you. If not i would dismantle it to check every cable which leads from cable input -> battery -> powerbutton and see if anything there got damaged.

Maybe search for some instructions or manuals for your notebook. Maybe there is sort of a section where you can find some informations about BIOS/CMOS reset. Maybe you really have to search for a CMOS Jumper - mostly those are 2 pins and near them theres a print on the boards with “CMOS JMP” or only “JMPR”. If you find something you can simply (if everything is unpluged from power sources) connect both pins with a screwdriver for some seconds and then your board should be empty.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Callum Haywood será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 8

Duração total: 825