Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

546 Perguntas Ver todas

Audio not working after Mojave update

I updated my MacBook Pro 2011 with MacOS Mojave and was trying to apply the update today, and I’m surprised no audio device on my system, any solution please?

Block Image

Block Image

Note! My system is not supported in MacOS Mojave I installed it with this method: How to install macOS Mojave on unsupported mac using DosDude patcher

Respondido! View the answer Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário

Free shipping on all orders over US$100,00 or containing a Pro Tech Toolkit!

Visite Nossa Loja

Ever fixed something? That’s Genius.

Share your repair story with #ImAGenius

We Are All Geniuses

Share your repair story with #ImAGenius

5 Soluções

Solução escolhida

GO TO MY YOUTUBE CHANNEL AND YOU GOTTA THE SOLUTION 100% WORK

https://www.youtube.com/watch?v=hJ5U7uaG...

Esta resposta foi útil?

Pontuação 0

Comentários:

Thank you i fixed this problem already.

por

Adicionar um comentário
Resposta Mais Útil

Did you install the correct patches on the patch updater? I have a hunch that you forgot to install a necescery patch.

I suggest doing a reinstall of Mojave, just be 110% sure you select all of the patches you can when you first initialize Mojave.

Update (11/03/2018)

I’m pretty sure you forgot to select the “Legacy Audio Patch” to be installed on this step.

Block Image

Reinstall Mojave and be sure to do it the right way. The creator of this patch has instructions on how to do this properly below.

http://dosdude1.com/mojave/

Esta resposta foi útil?

Pontuação 5

Comentários:

could be that too...

por

i was installing it in my MB i just updated it from App Store, what patch you talking about please?

por

@ayoub_tl You certainly did not just “update it from the App Store” because this is an unsupported machine. I’ll bet my reputation on this site that you used the Mojave Patch Tool or something of the like. Check my updated answer.

por

thank you so much, after i updated, i use this tool only for patch i didn't have to reinstall mojavi, and am still have the new update on my MB.

por

Adicionar um comentário

Basically you can’t use the auto update function or manually update via Apple as the update installer will wipe out your required drivers for your system. You need to stick with DosDude moving forward.

While I sympathize with you wanting to run the latest and greatest MacOS there is a point in time you need to bite your tongue and just sigh ;-{

The highest your system will support officially is High Sierra and its best just to stick with it.

Esta resposta foi útil?

Pontuação 2

Comentários:

It’s truely a shame that Mojave requires METAL capable GPUs, effectively making non-capable GPUs a giant nail in the coffin for the Macs they are soldered onto.

While these “patch tools” are great in the moment when you first install them, there are major headaches when it comes to updating Mojave as an OS because every time Apple updates Mojave, these types of loopholes get patched requiring you completely re-install them.

por

Adicionar um comentário

The simple answer - You should have not have updated to Mojave, there is a reason Apple does not include them on the update list.

What you can do - Find a way to uninstall Mojave back to whatever OS you were running before.

Can’t find out how to Uninstall?- Use an external speaker, it is the best you can do.

Esta resposta foi útil?

Pontuação 1

Comentários:

last version of mojavi is support my MB audio but when i updated it today its not support anymore

por

here is a link to test if you have a software or hardware problem-

https://support.apple.com/en-us/HT201257

You can rule out if it is hardware problems or mojave problems.

Follow the steps and tell me how it goes

por

The simplest answer is to continue using Mojave and the Patch Updater Tool !! I am running the latest Mojave Beta on my mid 2010 MB Pro 15" :-)

por

Adicionar um comentário

I had the same problem here, and the fix is really simple. Just open the Patcher Tool from your Lunchpad, and then click “Re-Install all”. After the installation, you will be asked to reboot your machine, and voila. The sound is back.


I hope this help.

Esta resposta foi útil?

Pontuação 1

Comentários:

but i did what you have said that.... but the aduio list reads 0 value even i asked to re install the patcher

por

Yes, this worked for me. Reinstalling all the different patchers and reboot. Even if I did not have the audio patcher selected in the list!

por

Adicionar um comentário

Adicionar a sua resposta

Ayoub será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 11

Últimos 7 dias: 143

Últimos 30 dias: 638

Todo: 1,241