Ir para o conteúdo principal

Mid 2006 / Model Number: A1181 / black or white case / 1.83 or 2.0 GHz Intel Core Duo processor

418 Perguntas Visualizar todos

battery shows "X" and is not recognized

A month ago, I inherited a macbook from a friend. He had spilled wine and fried the logic board a couple of years ago.

Prior to repairs, when I plugged the adapter, steady green light would come on - when I pressed the power button, I could hear the hard drive spin, but nothing would happen other than the sleep light come on.

I replaced the logic board - and voila! the computer comes on, no problem - everything works...except, now there is an "X" symbol on the battery - and a check of the system shows no battery is recognized. Unplugging the adapter shuts down the macbook abruptly. The DC has a solid green light.

I've tried the CMS and PRAM resets (as suggested in other posts), but no help.

I read somewhere that leaving a battery in the macbook for an extended period (as my friend did after the liquid damage had occurred) may cause the "X" symbol on the battery.

I've updated battery software with 1.2 AND 1.4. Still does not recognize the battery.

I have not had a chance to swap the battery with another unit - I don't have access to another unit - to see if battery is still good. How else can the battery be tested? Although I don't think the battery is the issue here (before swapping the logic board, I pressed the power meter on the battery and one green dot came on).

Any thoughts? My gut says this is caused by the battery sitting in the unit for a long time - but not sure how to fix. The new logic board (used, but new to me), seems to be working well in every other account. The battery connector, however, is from the old board.

Thanks for all your input.



Ok. Same problem. Except worse. Please Help. I have a May 2006 Intel Core Duo macbook. Everything works perfect except the battery. Cleaned everything up. Put in a brand new battery connector cable. Tried 3 fully functional batteries showing 5 green lights. Loaded coconutbattery. Shows:

Current Charge: -1 mAh

Maximum Charge: -1 mAh


Current Capacity: -1mAh

Design Capacity: -1mAh


Mac model:Macbook1,1

Age: 63 months

Battery loadcycles:-1

Battery temp:-0.0 C

Battery Power usage: -0.0Watt.

I am running Mac OSX 10.6.8.

Brand new hard drive

Brand new 2gb ram

Everything very clean.

This mac is phenominal!.....except for that little black x where the battery should be.

I went to the apple support pages above. I'm already running newer than OSX 10.4. I installed the battery updater. I reseated the battery many times with three different functioning batteries.

PLEASE PLEASE PLEASE HELP!!! I've run out of ideas! I cant take it to apple because I opened it up myself, but I need a professional.

I am not afraid to open it back up, but I need to know what's wrong.

Thank you very much!!!!!

Respondido! Ver a resposta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 1
Adicionar um comentário

2 respostas

Solução escolhida

Is the X red or black? There are 7 models in the A1181 series, please remove the battery and give us the specific machine so we can direct you to the correct part and service manual.

Download and run Coconut battery to see the status on it first:

My first guess is the battery connector, but lets see the results of Coconut:

Esta resposta foi útil?

Pontuação 3

8 comentários:

The "X" is black.

The serial number for the macbook is: 4H6290YOWBW

MacBook - MA472LL/A - MacBook1,1 - A1181 - 209.

I will run Coconut tonight and post the results.

Thank you so much for your help.



Apple MacBook "Core Duo" 2.0 13" (Black) Specs

Identifiers: MacBook - MA472LL/A - MacBook1,1 - A1181 - 2092


Here's the steps Apple recommends for the "X" problem:



So I downloaded coconut 2.7, but it wouldn't work with my OS X version - I'm running 10.4.11 (trying to fix hardware issues before upgrading OS).

So then I downloaded coconut 2.6.6 - but every time I launched the app, it would shut down unexpectedly. tried this for about 10 times.

Next, I went to the Apple article providing the steps. Tried to download battery update 1.3 - it ran a system check and said I don't need the update - not sure why.

I've only downloaded battery update 1.2 and 1.4.

I'm at my wit's end - should I just clean the battery connection> was hoping this was just a software issue.

Thanks for all your help on this.

Also - what if I reinstall the entire OS? I have the original CD. would that wipe the slate clean, so to speak?


Really, the first thing I would do is pop for the $29 and upgrade to the latest operating system 10.6.7. Cheap at three times the price. The upgrade may take care of the problem. If not, you will be able to use Coconut battery. Check your battery for swelling and or corrosion. Check the pins on the battery connector. Has it gotten wet?


Mostrar mais 3 comentários

Adicionar um comentário

here is the solution:

just clean the conectors and logicboard with contact spray or alcool, reflow for few sec and done :) ... fixed 2 of them .

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

armensemail será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 3

Duração total: 15,946