Water damaged iPhone with no visual damage or corrosion

Block Image

When i was taking off the shields i floated this chip and i lost it, can someone tell me the type of the chip, so i can get a new one.

I tested the screen and it works, all the connectors on the board are looking good, no corrosion or oxidation, i cleaned the board with alcohol , removed all the shields and visually inspected it, but still it does’t turn on. At the moment i do not have ultrasonic cleaner.

Respondido! View the answer Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

3 Soluções

Solução escolhida

The missing IC is U_LB_SW and it is part of the Low Band circuitry. IMHO, this is not a required IC and should not impede the phone from booting. If you want to replace it, you can either scavenge it from a donor board or order one on Aliexpress.

Daniel makes a good suggestion and if that isn’t the issue, the you need to start probing the circuitry to see if there any shorts. Start with VCC_MAIN, BATT_VCC and then move onto the PMIC outputs.

Esta resposta foi útil?

Pontuação 2

Comentários:

So in theory this missing IC wont't interrupt the work of the phone?

por

And yes i don't see any damage from water around the capacitor, but it should be somewhere on the edges because the water probably soaked from there.

por

I've never tried a board with that IC removed so I can't say for certain. However, it doesn't look (according to the schematic) like it would be critical. Worse case, replace it first and then troubleshoot.

por

Maybe the alcohol cleaning took effect but not on the same day, because today the phone booted up without a problem, so you were right about that ic.

por

Adicionar um comentário

did you check the capacitor beside the wifi chip before removing the shields as its the most common issue

Esta resposta foi útil?

Pontuação 1

Comentários:

No i didn't probe the capacitor before removing all the shields, i did now, and it looks fine, i tested around with continuity mode and it's not shorted nor any visual damage from water. Like Minho said now i will test VCC and then continue probing other lines to spot the shorted i guess.

por

that cap is vcc_main so it would have told you if vcc_main was shorted before removing the shields. check the battery connector to check for a vbat short

por

I was getting to think that it was a vbat short because there was no power, but then the screen turned on with some stripes on it.. So then i realize that the connector was little bended and loose. Тhe cleaning took effect!

And is it normal the CPU to get very hot when booting?

por

Adicionar um comentário

The home button’s flex cable caused the problem, because i tried connecting only the LCD and it works fine, but when i connect the home button to the board, the phone immediately goes off, or when i connect the cable while the phone is off it doesn’t turn on. Now i saw oxidation where the home button connects to the flex cable on the back side of the screen.

Esta resposta foi útil?

Pontuação 0

Comentários:

its possible i have had phones with bad home buttons before that caused the phone not to boot. as for the cpu getting hot it could be anything

por

Yup it's the home button!

But for the cpu, it gets hot only when booting, after that it's absolutely fine.

por

Adicionar um comentário

Adicionar a sua resposta

Angewolf será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 4

Todo: 101