Pular para o conteúdo principal

Charge port not working

I have a friend who sent his iPhone 7 plus into Apple because the charge port wouldnt work. He tried different chargers etc.

Apple says the frame is bent, so they wont work on it. The frame isnt bent. Sounds like a cop out to me by Apple.

I ordered a charge port and tested it externally and get nothing. I changed his battery and the phone comes on, so the phone is working. However, the original charge port and new charge port dont work. The strange thing is when the phone is off I can plug in the charge cable and it turns the phone on. So something is working, just not the charging.

iTunes doesnt recognize it, so I cant restore it. Im guessing at this point it's a board level issue. If so, what IC needs to be replaced?

Respondido! View the answer Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário

3 Soluções

Solução escolhida

@israel is correct. the "USB" Charging IC you are looking for is U4001, just make sure the Charging Port FPC Connector or any of the components surrounding it have not been damaged.

Block Image

Esta resposta foi útil?

Pontuação 3

Comentários:

Thanks. The inside of the phone is in excellent shape. I inspected the components to see if anything else was visibly damaged, but there was nothing. Ill update you when I get it repaired.

por

Adicionar um comentário
Resposta Mais Útil

You would be looking at the Tristar IC. Let me know if you need help!

Esta resposta foi útil?

Pontuação 4

Comentários:

Thank you. Ill update this thread when I get it repaired.

por

Awesome! Looking forward to your response!

por

Adicionar um comentário

Never saw an update, I have a phone right now I am looking at for someone doing the same thing. Battery is fine, not really wanting to do the charging port and order more parts if that’s not the fix. Did you find anything?

Esta resposta foi útil?

Pontuação 0

Comentários:

The company I sent it to couldnt fix it either. I didnt try another company, but it's probably something to do with one of the charge IC's. I dont do board level repairs, so Im unsure. Trying a new charge port without installing it all the way is possible.

por

Adicionar um comentário

Adicionar a sua resposta

Brian Wood será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 3

Últimos 7 dias: 16

Últimos 30 dias: 69

Todo: 3,034