Ir para o conteúdo principal

Lançado em 16 de setembro de 2016. Modelo 1660, 1778 Disponível como GSM ou CDMA / 32, 128 ou 256 GB / Ouro Rosa, Dourado, Prateado, Preto Mattte e Preto Brilhoso.

2126 Perguntas Visualizar todos

iPhone 7 Boot Loop issue with Front Camera/Proximity sensor/Ear Piece Flex

I have an iphone 7 that is stuck in a bootloop after screen replacement. Ive narrowed it down to the proximity/front camera/earpiece flex. When its disconnected phone powers up fine but when reconnected goes straight back into bootloop again. Have tried replacing flex cable twice with no luck so figure its a mainboard issue?

Respondido! Ver a resposta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 8

Comentários:

This is an issue that seems to exist quite frequently. I personally don't know how to fix it but maybe @danj or @mayer could give it a shot. Sorry I couldn't help more.

por

Thanks for the comment mate, hopefully will hear back from the guys you have tagged...

por

You bet you will

por

Sorry guys I'm not a iPhone hardware guru. Maybe Minho @refectio or Rany @rany can give you an answer.

por

@danj Sorry to bother you! I figured you'd know.

por

Mostrar mais 5 comentários

Adicionar um comentário

9 respostas

Solução escolhida

Ideally, you have to try a known-good FCAM flex. Small parts can be hit or miss, especially for something as new as an iPhone 7. If you don't have access to a known-good part, then the logic board needs to be verified to try and eliminate something.

What's probably happening is that one of those elements (CAM/PROX/ALS) of the circuit is defective. Once the flex is connected, it may be drawing too much current and forcing the some other power rails into current limiting mode. This will have to be looked at by a micro-solderer.

Esta resposta foi útil?

Pontuação 6

Comentários:

I had same issue. I believe that they key to resolving issue is to make sure that the front facing camera flex cable isn’t folded or bent incorrectly. I adjusted the flex cable to proper positioning and issue went away.

por

Same issue, just tested and can confirm that it’s the home button. Not sure why. Gotta sacrifice one lol. Good luck

por

Adicionar um comentário

I would try a complete assembly from a working phone, if available. In other words, try with a known good complete assembly. Sometimes new ones are bad too like mentioned by others here.

Also make sure you are connecting it in the correct orientation.

Finally, connect the front cam assembly without plugging the home button extension cable onto the board, see if that changes anything.

Only if using a known good assembly in the correct orientation yields the same result, can you then conclude that you have a board level problem.

Note: continuous boot looping may cause data corruption. Pull a back-up before testing any further.

Esta resposta foi útil?

Pontuação 6

Comentários:

I have same problem, after desconnected homebutton front facing camera work and phone boot. What have front facing camera flex and homebutton conjucted?

por

Probably a data line. Haven't had time to check the schematics.

You can try a different screen just to make sure the issue is not due to the Home Button extension cable built into the replacement screen.

por

it was the home button cable . i try disconect it and try and boot lop gone!!.

por

I had the same issue, customer dropped her phone and the home button stopped working, Turned out the button cable had torn. I replaced the screen and it was constantly boot looping, booted fine without the front flex attached. Saw the comment on here to disconnect the home button and it worked absolutely fine. Customer knew the home button would no longer work so I just snipped off the home button connector and put it back together.

por

@Rany Where is the "home button extension cable" connection that needs to be disconnected in order to troubleshoot this?

por

Adicionar um comentário

Not sure if solved yet, but I had this exact issue, phone will bootloop, but when sensor flex is disconnected it will boot up fine. Strangely enough this was due to a small tear in the flex cable that connects the home button to the board. And when this cable is disconnected the phone boots fine even with sensor flex connected.

Hope this helps

Esta resposta foi útil?

Pontuação 2

Comentários:

Isn't there 2 connections for the Home button? I suppose no way to keep Touch ID with a torn home button flex...?

por

Adicionar um comentário

Just in case anyone finds this question and possibly did the same thing as me, check to make sure you’re putting the cable the right way…. I tried putting it in upside down because I wasn’t following the guide as I thought I knew what I was doing… Found that out after I bought a new sensor/camera cable.

Esta resposta foi útil?

Pontuação 2

Comentários:

Fixed many iphone's over the years and never thought that i would do the same thing and be placing the cable for the front camera the wrong way around. %#*@ i feel stupid :D Thank you so much

por

Ok been scratching my head for awhile. 100% true. Guess it’s some sort of safety feature. Ya make sure you have the flex cable in the right way!! Boom should work ??

por

Adicionar um comentário

I had issues with sensorflex as well, first replacement resulted in bootloop, second replacement, no speaker, no proximity

I just fixed these two sensorflex by re-soldering the contacts under the sticker, the factory soldering was bad, even on the flex that I pulled from the original phone

Block Image

Also the proximity frame on the new display “OEM quality” did not align with the sensor “eyes”

Block Image

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

me facing this same issue on iphone 7 , its very clean PCB , when connect front cam senser cable its gone bootloop, if disconnected the phone will boot up normaly , i already changed the senser cable both(ORIGINAL and COPY), i dont understand exactly what will be the right issue , also i found there is no any short cercuit in normal mode, let me check it well ,

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

I had the same issue… phone would boot only when I had either the Front Facing Camera Flex Removed or the Home Button Removed… a new screen assemble sorted the problem.

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

I had struggled with this problem but found a different issue that solved my troubles, there is a screw that sits above the front camera housing on the screen. See yellow circle in the attached image. This was missing in the new screen. once replaced the phone booted up straight away.

Block Image

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

I had the same problem, client came in the shop with iphone 7, he tried to replace the display but broke the homebuttonflex. Try to boot without the homebuttonflex attached!

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Rhyan Perso será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 3

Últimos 7 dias: 24

Últimos 30 dias: 132

Duração total: 12,804