Pular para o conteúdo principal

The March 2015 update of Apple's 13" MacBook Pro Retina Display, model A1502, features fifth-generation Intel Core i5 and i7 processors and introduces the Force Touch trackpad.

560 Perguntas Ver todas

My Function keys are messed up. Volume & Brightness keys don't work!

So yesterday I successfully changed my Macbook Pro Early 2015 trackpad.

All the parts were put on right places and nothing left wrong. After I turned on my Mac everything was working perfectly including my new trackpad.

But! Then I found out that my Function keys don't work properly. When I press them they do work correctly, but they don't do the stock commands like turning the volume up, down, brightness, next song etc ... Instead my volume button takes me to the dashboard with a whole new commands for these buttons.

I have been into the whole keyboard options and have done almost everything like ticking off the mission control settings. Unchecking the F1, F2 as standard keys etc. Everything like this is done.

Still! I can't manage to get the factory commands back. I really don't know how this happened.

I have tried PRAM and these kind of things without any luck. Notice that all the keys do work and nothing is damaged on the hardware, because when I press them they do work but in other ways.

I didnt have this problem before the repair. It is difficult to believe that the repair may have caused this because all the buttons do work properly, but does other things.

Update (01/11/2017)

Block Image

Here is a SS of the USB settings.

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 3

Comentários:

I was expecting to see the Apple Internal Keyboard / Trackpad entry under the USB devices listing it's not there! I've not worked on these newer models yet so that was a surprise. Looking deeper into this model I see they don't daisy chain the keyboard via the trackpad mechanically as they did in the older models as well as use the internal UDB hub connection. The both the keyboard & Force Touch trackpad must use a different connection to the system (PCIe?) You'll need to walk though the different hardware sections to see if you can find the interface. That might offer a clue here.

por

@alandoski have you figure out the problem? Because I have the same issue, I have changed the trackpad on my MacBook Pro late 2015, and my Fn key messed up.

por

I also cant use my Function keys, and even though I did the System preferences method, all my laptop does is make some sound every time I click on one of the F keys. When I click F12, something black with graphs and a zoom in/out button on the corner appears.

por

Adicionar um comentário

kits de reparo de baterias de iPhone

Only $29.99

Buy Now

kits de reparo de baterias de iPhone

Only $29.99

Buy Now

3 Soluções

Resposta Mais Útil

Have you tried deleting and reloading the 'Input Source' keyboard?

I would recommend setting up a second keyboard first (USB or Bluetooth) just to be safe here!

Go into the Keyboard Prefs setting window and click on the Righthand menu choice 'Input Source' now hi light from the left column the keyboards flag (in my case a US flag) using the minus key at the bottom, then close the window and restart the system, then reopen to add it back in. Did that solve it?

We will need to know what are your keyboard resources are. Go into 'About This Mac' Click on System Report. Now in the left column expand Hardware section and then click on the USB. Now in the Right column grab the cross bar and slide it up so the Keyboard & Trackpad resources are all visible. Take a screenshot of the window and paste it here for us to see.

Also tell us what your OS is and what is your keyboards language (US, British, French ...)

Update (01/11/2017)

Well, I think you have a bad keyboard here.

I assume the reason you replaced the trackpad was do to a liquid spill of some sort. Sadly, what ever spilled also effected the keyboard.

I would visit an Apple Store and see what they have to say is the issue. Once they report back to you on whats wrong you can decide if you want them to fix it or give it a try your self.

Esta resposta foi útil?

Pontuação 2

Comentários:

I tried the first thing you said about the minus, but it did not help at all. I didnt have a bluetooth keyboard so instead I used my phone as a trackpad and keyboard (Application) and tried the F keys and still they are like that. That means there is no damaged keys and they work. My language is Norwegian, but note that the F keys worked all of them, I cannot believe how the F keys are mapped or something ,really strange.

I posted a picture now.

por

But if this was a bad keyboard then the bluetooth keyboard should have used the f keys correctly. When both keyboards give the same results it means that it must be something on the software?

por

I would still visit the Apple Store to see if they can explain it. I'm at a loss why the external is likewise having the mis-mapped function keys as well.

por

I figured a way to fix the Screen brightess and volume keys by using Keyboard Maestro and mapping these. However now my life works again, but the only problem is rest of the keys. I am afraid of going to Apple Store and they taking my Macbook or something because I repaired it by myself.

por

You'll be fine! Don't get paranoid here ;-} They can't keep it as you own it! All they can do is say no.

There have been times they have pulled a rabbit out of the hat for me so don't be so quick not to go (unless its just not possible).

por

Mostrar mais 3 comentários

Adicionar um comentário

The trackpad was probably damaged by a bulging battery pushing and breaking the trackpad due to poor design. I’ve experienced this on two MBP and am pretty fed up with it since the battery and whatever damage it makes isn’t covered by warranty and Apple doesn’t take responsibility for faulty design.

Two days ago after connecting to my Apple TB monitor at home with and Apple USB keyboard (and BT trackpad) connected I experienced the same malfunction of the volume keys as stated above in one of our families MBA and I’m pretty sure it’s due to really unstable OSX nowadays. Has it really been that long since the late S.J. went 6ft under?

Hardware and software that used to be “it just works” -which lead me to replace my families entire eco system several years ago and contiously adding new Apple products- seem to be dropping like flies and is nowhere near anymore.

Volume /function button problem:

[Fn] button working since double press opens the “dictation” pop-up and all F1-12 work correct wile the default functions like brightness and volume are gone. I’ve tried activating and deactivating “Use F1, F2…” and also disabled “Show desktop/dashboard” for [F11] and [F12] while the latter two were never activated by myself. On the external USB Apple keyboard everything works correct.

So, no keyboard hardware failure but instead I’m confident a full clean install will do the job like in the days of crappy Windows unless someone can come up with a solution to restore functionality which wasn’t altered by myself…

Esta resposta foi útil?

Pontuação 0

Comentários:

Hi, I'm wondering whether you have found a solution as I have an issue just now which sounds a little similar... (Volume up key F12 reduces screen brightness (as well as affecting volume, and screen brightness key affects brightness AND volume)... I am not v technologically minded - you sound like you are wondering about re-installing OS? Did you do this/did it work? My MacBook Air has Mojave installed presently, but this has been installed for perhaps about a month and issue only started yesterday.....

Thanks in advance for any thoughts!

C

por

Adicionar um comentário

If unchecking Function keys nor SMC and PRAM reset don't work, it can be a Key-remapping issue related with a hardware security mechanism against malware (as explained in the last post in https://discussions.apple.com/thread/654...). Apple uses in store a non-accesible software tool. For me, the solution was just installing and opening this program: https://github.com/tekezo/Karabiner-Elem....

Solution taken from https://apple.stackexchange.com/question....

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Alan Doski será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 24

Últimos 7 dias: 201

Últimos 30 dias: 906

Todo: 33,819