Ir para o conteúdo principal

Released October 24, 2011 / 2.2, 2.4, or 2.5 GHz Quad-core Intel Core i7 Processor

437 Perguntas Visualizar todos

My MBP 15'' wont boot - battery or not?

Hello everyone.

It has now been 2 months since my MBP quit on me and I'll try to go through my troubleshooting process and history:

Before it died

Last summer I bought extra ram and a SSD for my MBP. It worked like a charm and I had no issues whatsoever.

Later - I was traveling through Myanmar this fall and at one point I found a cafe that actually had internet and a single plug I could use to charger my laptop with. I plugged in my original charger and heard a small 'clonck' inside the transformer. My computer was not connected to the charger when it happened.

My next stop on the trip was Hong Kong and I decided to find a new charger there. I bought a fake charger and it worked like a charm.

The day it died

I was in mid/end November, about three weeks later, while I was traveling through Vietnam. I was working, well knowing, my MBP would run out of power at any moment, but I decided I had worked enough and as it went out, I closed it and drank a few beers instead.

Three days later I had to get some work done again and I when I plugged in the charger it had a very faint orange color. Before I googled anything I kicked myself for buying a cheaper copy adapter.

My troubleshooting

I found the closest authorized store was about 300 KM south of me and when I finally reached the city a couple of days later, there were about 15-20 stores that looked 'legit'. Mind you that by the word legit regarding Asia - it would not have been in Europe or America. Anyway, I trust I found the actual store, since everyone else had quite cheap adapters and the one I bought was about the same as back home.

When I finally plugged it in, the same faint dim light came on, so I googled it.

I found a bunch of people having the same problem and everyone saying it helped unplugging and/or removing the battery and putting everything back together again. This did not work.

Then I had a few articles saying I should remove the battery from the case and connect the MBP to the adapter. The articles mentioned the motherboard now would run by itself and I could tell by the running coolers. Nothing of this sort happened and when I put it back together, it was bright green for a moment and then it went back to being faint green and on to faint orange.

Bested by this issue and no guide seemed to work, I wrote on a few different foras online. No one had an answer, except: "Your battery is ruined", "Change it".

Now home again

Since then I've been working out of an iPad, which was complicated. I decided, hoping for a miracle, to connect my MBP to the power adapter and hope to boot it. It went directly to a bright orange and seemed to charge. I gave it 2 min. before trying to boot it, but nothing happened and it doesn't even give the slightest sound.

My mate told me to take out the battery and leave it for a few days to make sure it was 100% empty and then try again. I did so, still no change.

Battery or Not?

I decided it was the battery and I am about to order a new. However, I pressed the small "check your battery charge level bottom" or whatever you want to call that tiny bottom. It started out with just 1 green dot and having one blinking, I checked again a bit later and it was on 3 with 1 blinking, indicating it was charging.

Now it is almost full - yet still no sign of life from my old MBP.

I am kind of hoping it is the battery, since that it probably the easiest and cheapest to change. Does anyone here know if it is or if it is something else (more serious) that could be wrong?

Thank you for reading and for your suggestions!

I'm sorry for the long post!

Respondido! Ver a resposta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0


If I remember correctly any MacBook without a battery should turn on when plugging in the charger.


I had heard the same thing. One thing I forgot to mention is that I took it out after I got home and closed it op without the battery, plugged the adapter in - nothing.


Adicionar um comentário

1 Resposta

Solução escolhida

Disconnect the battery and inspect the logic board for liquid damage. Check the area to the right of the RAM slots (charging chip which says ISL6259) for any burnt pins or components. With the battery disconnected, plug in an original Apple charger, leave it a minute and feel the chip. If it is getting hot, this is likely the issue and will need to be replaced, this usually dies when using 3rd party chargers. This should boot with the battery disconnected.

Unless the charging port pins are dirty or burnt, this will need logic board repairs. If you have not soldered anything before, I would recommend sending it somewhere.

Esta resposta foi útil?

Pontuação 1


Alright. Opened it up and disconnected the battery. I honestly can't seem to find a chip with ISL6259 on it, but i've got a pretty good guess. I found one just to the right of the RAM slots (when the front/opening faces me) which says: I6269.

However, leaving the charger in with a disconnected battery does not heat this chip. Nothing seemed burned, but I most admit I haven't seen it before either.

I've taken a picture of the inside and one close up. Any chance you could be even more specific and refer to the pictures? Thanks a lot so far!


Yes that's the one, the top of the chip says "i 6259...", but it is known as the ISL6259.

If it is not getting hot or warm, you need to check PP3V42_G3H voltage using a schematic and board view. You should also check PPBUS_G3H, since this is outputted by the charging IC. If PPBUS and PP3V42 is measuring correctly, try a new charger port.

Have you removed the board to check underneath for any liquid damage?


Adicionar um comentário

Adicionar a sua resposta

Henrik A será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 2

Últimos 30 dias: 15

Duração total: 168