Pular para o conteúdo principal

After replacing BT/WiFi card and cable, no Wifi hardware installed

The other week, all of a sudden, I got a message on the menu bar saying "Wifi: No hardware installed." This is on a mid-2010 MBP 15-inch. Tried resetting SMC, did a OS update. No change. The Bluetooth worked fine, just no WiFi. Went to iFixIt, found that they had WiFi cards and cables, ordered one of each and installed them. Still no WiFi (BT still works fine). I am now awaiting an external WiFi adaptor from Other World Computing to see if that can give me back some WiFi. Given the age of this laptop, I don't want to invest in a new motherboard. If this is merely something related to the OS, I am looking at wiping the HD (I have two installed now, a SSD as a boot drive and a SATA HD as a second, larger drive); I am looking at combining the two drives into a single Fusion drive to make better use of the storage and have one logical drive to deal with. Any suggestions on what else may cause the WiFi to stop would be appreciated.

Respondido! View the answer Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0

Comentários:

I would double check the three, gold airport antenna cables are seated properly. Also, the airport wireless card has a cable that attaches to the logic board and the assembly itself. I would check that also and make sure it's seated properly.

por

If it is saying no hardware installed, it is not detecting the wifi card (gold antennas are for strength, so this does not stop it detecting the wifi card if not plugged in).

por

Adicionar um comentário

iPhone X Fix Kits

Warranty up? No worries, we’ve got the fix.

Comprar agora

iPhone X Fix Kits

Warranty up? No worries, we’ve got the fix.

Comprar agora

1 Solução

Solução escolhida

Will most likely be L3404 (component to bottom right of wifi cable connector, between 2 others) or L3401 (double ferrite bead directly under the wifi connector, on other side of board). These commonly burn out.

Measure top of L3404 to make sure you get 3.3V for wifi power. If not this, will most likely be L3401 or caps in this area.

Either way, it is a logic board issue if you have tried a cable and card, so it is up to you whether you take it on :)

Esta resposta foi útil?

Pontuação 2
Adicionar um comentário

Adicionar a sua resposta

rsteinbart será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 0

Todo: 116