Pular para o conteúdo principal

Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

882 Perguntas Visualizar todos

Trouble Identifying an SMD component on the logic board

Hello everybody,

My logic board got wet and a particular component got fried as a result. After cleaning off the corrosion one of the pins was so corroded it broke off and the component needs replacement.

I asked some of my electrical engineer colleagues and they could not identify the component in question so I was hoping someone here could help.

Block Image

Block Image

The component in question has a red box around it and the label

"1127 9M2 5285"

due to its proximity to the magsafe board and my laptop being completely unresponsive I believe it has something to do with the charging/power circuit.

If anyone could Identify the component in question and suggest a replacement I could give fixing this a shot. It's 7 years old but I'm not ready to give up on it just quite yet.

Respondido! View the answer Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário

1 Solução

Solução escolhida

You are correct, it is a mosfet related to the charging circuit. Common for the pins to get burnt on this year if liquid damaged.

It is Q7001 (Apple's reference) if the board number is definitely 820-2530. Code for mosfet is HAT1127H, which should let you find it. Best thing is to swap it from another dead logic board if you have one.

Clean it more thoroughly around the LCD connector. Looks like you may need a new LCD connector and the onewire via is probably fried (5 pin chip bottom left of LCD connector in your picture)

Esta resposta foi útil?

Pontuação 1


Thank you, I have ordered the part! As for the other parts I will do a more thourough cleaning but in the past i have taken this laptop apart and noticed the same discoloration, figuring it was dust. If the mosfet replacement doenst work i will go there next.


I managed to replace HAT1127H and did a onewire fix. The battery is currently charging and the led indicator lights show progression.

When pressing power the fan and hard drives spin up but nothing else happens. I have tried to reset SMC and PRAM but to no avail.

Have also tried hooking up to an external monitor but also no luck.

Any ideas?


It's not passing post, which could be caused by a lot of different things. Check all power rails using a schematic and board view to make sure all S0 rails are present.


Adicionar um comentário

Adicionar a sua resposta

dproosdij será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 0

Todo: 152