Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

1082 Perguntas Ver todas

After replacing Hard drive folder with question mark and not recognize

Hi,

I have a mid 2012 macbook pro (OSX 10.10.1). Just bought my new Samsung 850 Pro 256gb SSD disc and whant to replace with existing. Tried out several methods:

1) Cloning old hard drive to new - then I replaced it and I got flashing folder. Tried resting PRAM (cmd+option+P+R) - still the same. It did not even recognize it.

2) Then I tried to install from my OSX flash - opened Disk Utility - formated everything - Journaled + GUID. Tried to install, but at the last second I got - "Mac OS X cannot be installed on this computer"

3) Thought maybe the cable is broken, but when i reconnect the old hard drive, everyhting works perfectly. Only when I connect the new one nothing works. If I connect my new SSD through USB I can boot it and everything works.

Can anyone please help me ?

One thing I noticed, that I am not really clear if that could be the issue - when I try to verify, it says that there is some kind of EFI problem - could that be the issue?

Respondido! View the answer Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 1

Comentários:

Help us help you. The more complete the description of your problem is ( a full compete description, of the text or a screen shot of any error messages) the more assistance we can provide, and, the sooner we can provide it. Stating there is some kind of EFI problem is significant, but too vague to be useful

por

Adicionar um comentário
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

4 Soluções

Solução escolhida

I would put your old HD back into your system and then make sure everything is working first (back to square one).

Now lets try using Disk Utility to prep the SSD using the universal USB adapter cable or external case. Are you able to get it prepped with the OS? If not then you have a hardware issue in either the case or the SSD.

If you are able to get it setup with a working OS. Press the Option during boot up to get the Startup Manager to then select the SSD as the boot up disk (reference this Apple TN: Startup key combinations for Intel-based Macs. Did it boot up? If it did you should then be able to open your system and swap out your HD for the SSD.

Things to watch out for:

Some SSD's will not work if you are setting up a dual drive setup in the optical drive bay and in fact swapping the HD over to the optical bay location may not be workable either. You also can hit a SATA port speed issue in older models where the SSD is not able to run at the same SATA I/O speed of the HD SATA port.

You may want to review this if you are doing a dual drive setup from OWC: Optical to SATA Drive Converter Bracket Solution. It makes no difference who's product you have this is an Intel controller issue in the given model.

Esta resposta foi útil?

Pontuação 2

Comentários:

As to the EFI Q: I would make sure your iMac's EFI firmware is the newest. Follow this Apple TN: EFI & SMC firmware updates for Intel-based Macs.

por

Adicionar um comentário

Just replace the HDD ribbon it'll fix it. you can buy one on amazon for like $40.

Esta resposta foi útil?

Pontuação 0

Comentários:

Sam the issue is not the cable here as the HD works when reconnected. This is a known issue related to SATA speed incompatibilities when using a dual drive setup.

por

Adicionar um comentário

You may need a SATA-6 cable instead of the stock SATA-3 cable. I used the IF163-041-1

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Hello

I have exact same problem as yours. And I tried almost every possible way to get it solved, but unfortunatly it was not possible. The only thing I have'nt encountered with is that EFI problem.

And whenever I'm trying power+option key, and then choosing the external disc ( my samsung SSD connected to my Mac via USB), it boots but after a few seconds the prohibition sign appears, then I disconnect my SSD by pulling the cable and then immediatly connect it back, after few seconds the prohibition sign disappears and the boot loading continues from where it left before.

Any Help. plz?

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

klavinsainars será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 2

Últimos 7 dias: 13

Últimos 30 dias: 102

Todo: 9,282