Ir para o conteúdo principal

The Sennheiser RS 120 is an RF wireless headphone system with open, supra-aural headphones.

52 Perguntas Visualizar todos

Why doesn't my transmitter turn on?

The green transmit lite on my transmitter doesn't

come on anymore to indicate the unit is transmitting.

It isn't transmitting. All connections are ok.

Any advice??


Paul Hipp

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 9
5 comentários

i have an issue where the green light is intermittent at best and these are brand new straight out of the box

it doesnt matter which outlet i plug it into


Hey, I have same problem. Have you resolved it, at last?




hey, i have got the same problem

I contacted the service centre and they seem to solve the problem


why cant i tune in the frequency on my headset


I have the same problem as above - intermittent green light, no transmission. Red light charging OK. Slapped its bottom and green light comes on, but only for a minute or so. Lots of static volume but will not tune in. Would appreciate any help you can give me. Cheers.


Adicionar um comentário

5 respostas

Pergunta mais útil

I found this and incredibly it worked for me too!

Just use another power strip

"...I realized an extra device had been plugged into the power strip. It appears the strip may have been overloaded. Tried again with a new strip (careful not to load too many appliances this time) and the green light came on properly."

Esta resposta foi útil?

Pontuação 5

3 comentários:

I tried every input signal and no dice, then I just unplugged and reinserted the power in the same strip. It started working immediately.


simple and effective solution. Thanks!

Who would have thought that a power outlet would discriminate power usage? (:


Did work for me too! I had this problems many times, and I just waited for it to work... thank you very much


Adicionar um comentário

No green light?

Disassemble the transmitter and tap the crystal with power on. use non conductive tool !

The crystal is up front and has a shiny case.

I suspect a component value has changed and the oscillator circuit fails to start.

By tapping the crystal it starts the oscillator.

This makes the unit work until power is removed.

…or give the unit a sharp slap with the palm of your hand…that gives same result

..anyone have a circuit diagram to post? I may be able to determine the fault.

Esta resposta foi útil?

Pontuação 2
Adicionar um comentário

We'd had a thunderstorm the other day and our house power flickered - that must be when it stopped working.

No green light with any input. After I unplugged the power supply and then reinserted it the green light came back, we were working again. Phew!

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

I just had this same issue. Same thing, changing plugs and back fixed it. Apparently, mine took issue with the surge protector they were plugged into. But now the exact same setup is working after getting it to turn on from another outlet.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Hello. I had the exact same problem, and it was solved following the procedure on this page :

In short :

  • disconnect both power and audio from the base, remove the batteries from the headgear ;
  • let it sit like that for 15 minutes, enough time for the electronics to relax ;
  • then plug the power back in the base, put the batteries back in the headgear, check whether the red "charge" light goes on, and finally plug the audio back in the base.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Paul Hipp será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 17

Últimos 30 dias: 75

Duração total: 12,779