Ir para o conteúdo principal

Model A1419 / Late 2013 / 3.2 & 3.4 GHz Core i5 or 3.5 GHz Core i7 Processor, ID iMac14,2

322 Perguntas Visualizar todos

No backlight after adding SSD drive

Hi to everyone!

This is my first time here posting a question, although i have always been a regular user of iFixit, helping me with a lot of issues. However, I'm having a strange problem and cannot find a specific answer for it.

As a start, sorry for my english not being it my first language. I have disassembled today my iMac to add an Apple SSD Drive 128Gb so I would enable Fusion Drive (having a 1TB HDD 7200rpm). Everything went smooth, but when I put everything together, there was no image on the screen. Having disassembled notebooks, computers for about 12 years, tried the usual troubleshooting and came to the conclusion, with a torch in my hand, that the LCD was working, the iMac booted fine, but there was no backlight. So i took out again the LCD, tested the cables on the back of the LCD thinking i had torn any of them. Tested the display cable, the power cable of the lcd, everything ok. I then thought it was maybe a problem with the light sensor, or maybe the light was dimmed at it's lowest value, nothing. Reopened the iMac, removed the SSD drive, still the same. Has this thing happened to anyone of you? I can't seem to find nothing about the new iMacs, only about the older ones.

Hoping for an answer.

Respondido! Ver a resposta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0

Comentários:

Well, 6 months later, after buying a new LCD and a new logic board, i have the same problem. Now i have two logic boards, two displays and a non working iMac. Has anyone found any solution to this problem?

por

Please give us the last four figures of your serial number (located on the bottom of your stand).

por

F8J4. Thank you

por

Does anyone have any idea on the solution for this problems. Its strange that even after changing the logic board where the led driver is , i still have the same problem. Is it possible that the ssd that i installed could be the problem? How can it damage the LED driver

por

Adicionar um comentário

2 respostas

Solução escolhida

Finally i got my iMac working. The problem was that 1 pin of the LVDS cable (Or the DisplayPort Cable) was disconnected from the cable. So for anyone that might have a problem like this, with no backlight, on the iMacs 2012 or newer that have the backlight controller integrated on the motherboard, make sure that the Cable that connects the display data to the motherboard, is not damaged. I had to put it under microscope, because there was no way to find it out just looking at it, considering how small those pins are.

Although the LEDs have a power connector, if the DisplayPort cable (LVDS) cable does not send the command to power on the LEDs, it will not power them.

Take a look at the picture.

Block Image

Esta resposta foi útil?

Pontuação 5

Comentários:

Thanks, that helps me a lot, the PIN of LVDS cable is so tiny and the rightmost PIN on the connector is very easy to bend, it is hard to notice that if I did not see this post!

por

Adicionar um comentário

While I can't offer you much of an answer here:

The reason you can't find much on the newer systems is they are harder to open than the older units, which is why many people have not ventured inside.

As to your problem:

Check your displays power ribbon cable connecting to the logic board and its connector did you damage it? Also if you did not seat it fully before powering it up you could have blown something.

Esta resposta foi útil?

Pontuação 2

Comentários:

Thank you for your quick answer. Can you please tell me the voltage for the LED because i don't have any voltage on the first three pins (being 6 pins in two groups, each group powering the left and the right) i get no voltage. Does it also mean that at least half of the display should have light?

por

After 5 hours working on it, it turns out the problem was with the leds. While removing the display in the lower part, there was some pressure applied which caused the led board to be disconnected from the display (there is no way to make it work, although i disassembled the whole lcd). I don't know how to add pictures in here for anyone else having the same problem

por

I still have the problem with this iMac. It's driving me insane. After two new motherboards replaced and two LCD 27", there is still no backlight from the LCD. Anyone have any idea?

por

Sorry to hear you are still having problems, I thought you solved things.

por

Can you tell us if you can see the faint image of your desktop by shining a flashing at an angle to the display? Have you been able to try an external monitor to see if the desktop os visible on it? If you can see the desktop with both then you need to focus on the backlight services.

por

Mostrar mais 1 comentário

Adicionar um comentário

Adicionar a sua resposta

Ermal Turkeshi será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 6

Últimos 30 dias: 14

Duração total: 914