No Service after repair! :( Might have broken a component.

The phone worked fine before I did the repair, but I believe I may have broken a component on the board with a screwdriver. Can someone tell me if this component in the photo is related to cell reception? And which components I should look at to determine if they may be damaged?

And is there is an easy way I can go about fixing it?

Thank you to anyone that might offer suggestions.

http://www.imgur.com/Mo3Z6T0

Block Image

EDIT: Now I found another component that appears damaged, couldn't his one be the culprit?

http://m.imgur.com/SWMfwOh

Block Image

Respondido! View the answer Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 2

Comentários:

My 5s fall down display broken .. I replaced display but showing no service. What is the compliant. Which part become complaint

por

Adicionar um comentário

4 Soluções

Solução escolhida

Cameron,the first image shows C201 missing. That is a 56PF 6.3V 5% capacitor in a 01005 package. It is part of your CG flex connector circuit. The second image shows C242 missing. Coincidentally enough, that capacitor has identical values and is part of your headphone detect circuit. Neither one of those is directly related to your reception circuit. As for fixing it, sorry no easy fix. Those components are rather small and require special tools and skills to be replaced. Hope this helps, good luck.

Esta resposta foi útil?

Pontuação 4
Adicionar um comentário

My only question would be did you try turning the phone on again? like does it still work? I am curious because its hard to tell from the photos what your indicating.

Esta resposta foi útil?

Pontuação 0

Comentários:

Yes it works fine.. Everything works on the phone except for the reception. But I cannot figure out why.. I have already replaced all components related to the cellular antenna (like the lightning connector assembly) and screws holding antenna to the frame.

por

Can you detail all you have done or upload a little bit clearer pictures? I apologize my eyesight is horrible. It looks like you may have broken it but i would need a clearer or bigger picture to be absolutely sure.

por

Adicionar um comentário

You should carefully clean all the connectors and make shure that tey are well clipped. It happened to me on an iPhone4. The + volume button was the only one that was not working, so ... check and clean conections !

Second option ont he same iPhone 4 after a screan change the repair man had to connect and disconnect the iphone to itunes (or maybe a special soft) to make the service back again. He was aware about this sublety and make the service work just after the repair

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

usually they are resisters and its hard to determine the resistance. a alternative would be to jump add a jumper.

use flux and a soldier iron and some vary little solder and bridge the connection.

be sure to disconnect power and remove battery from area were you will be applying heat.

always remember to take your time.

Esta resposta foi útil?

Pontuação -1
Adicionar um comentário

Adicionar a sua resposta

Cameron será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 9

Últimos 30 dias: 82

Todo: 9,140