Why can't I format nor copy files to 6Gbit/s SSD in optical bay?

I've replaced the optical drive with a SSD SATA 3.0 6Gbit/s Samsung 840 Pro in a optical bay hard drive enclosure but I can't format it nor copy files (a few files work) to it. I have read that some MacBooks only support 3Gbit/s in the optical bay but when I check my SATA chipset on my Mac it states both chipset offers 6Gbit/s.

When I put my SSD in a external case and connect it to my Mac through USB I can format the SSD and copy files to it. So no problem with the drive, right?

Do I still have to place my SSD in the main bay and put the old HDD in the optical bay to make it work? And if so, will my Mac automatically boot from the HDD on the first boot even though it's in the optical bay? Or do I have to clone it first?

Thanks in advance!

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0

Comentários:

Okay a few hours later I have now fixed the problem. I switched the two drives so that my SSD runs from the main bay and the old HDD from the optibay.

But it wasn't simple to figure out since my Mac states both SATA connectors support 6Gbit. Bottom line for future iFixers that encounter similar problem: Don't use a fast ( SATA 3.0 6Gbit/s) SSD in the optical bay! Any slower disk than SATA 3.0 should work.

Some models of MacBook Pro seems to work properly even though it states 3Gbit on the optical bay connector, but if it seems to work you will be limited to that speed. If you're unlucky, like me, your connectors says they both support 6Gbit but it still won't work.. You can reed more about supported speeds and how to check what link speed capability your Mac support here: http://goo.gl/I2mYSZ

Oh, and about the first time I booted my Mac: my Mac booted from the old HDD (where I had OS) in the optical bay automatically. Then I cloned the HDD to the new SSD and chose it as Startup Disk in System Preferences.

por

Adicionar um comentário