Pular para o conteúdo principal
Ajuda

Versão atual de: Andrew Optimus Goldheart ,

Título:

iMac 27" Black Screen

Texto:

iMac 27" 2009 i7 2.8GHz

I bought this machine and the V-Sync cable was damaged and during transit from the seller it stopped working due to the munched up 4 contact pads on the flex connector. I temporarily fixed it by using crazy glue under the tracks and pushing the contacts back down onto the plastic strip. Cleaned off the contacts and got the display back. However, I had to take it apart again and next time I reassembled it would not work. I received a replacement V-Sync cable from the seller and tested it with a multimeter. Contacts all in good shape (under my microscope). Replaced it but I still have a black screen.

Have reset SMC and PRAM, tried Command F2 to make sure I was not in display mode. Shining flashlight on screen it does not have an image so I do not think this is just a backlight issue. I also tried an external display and it also does not show an image.

If the backlight board was blown I am assuming it would not affect external display but when I had the bad cable initially it also would not display external. Can someone confirm if a bad backlight board could cause these symptoms? What is the most likely culprit? Maybe the 4850 graphics card? Could the Display Panel itself be damaged from this cable being defective? But that wouldn't explain no external display...

Open to ideas....

dispositivo:

iMac Intel 2727" EMC 2309 and 2374
iMac Intel 2727" EMC 2309 and 2374

Status:

open

Resposta Aceita:

91230

Editado por: oldturkey03 (detalhes da votação) ,

Título:

iMac 27" Black Screen

Texto:

iMac 27" 2009 i7 2.8GHz

I bought this machine and the V-Sync cable was damaged and during transit from the seller it stopped working due to the munched up 4 contact pads on the flex connector. I temporarily fixed it by using crazy glue under the tracks and pushing the contacts back down onto the plastic strip. Cleaned off the contacts and got the display back. However, I had to take it apart again and next time I reassembled it would not work. I received a replacement V-Sync cable from the seller and tested it with a multimeter. Contacts all in good shape (under my microscope). Replaced it but I still have a black screen.

Have reset SMC and PRAM, tried Command F2 to make sure I was not in display mode. Shining flashlight on screen it does not have an image so I do not think this is just a backlight issue. I also tried an external display and it also does not show an image.

If the backlight board was blown I am assuming it would not affect external display but when I had the bad cable initially it also would not display external. Can someone confirm if a bad backlight board could cause these symptoms? What is the most likely culprit? Maybe the 4850 graphics card? Could the Display Panel itself be damaged from this cable being defective? But that wouldn't explain no external display...

Open to ideas....

dispositivo:

iMac Intel 27 EMC 2309 and 2374

Status:

open

Resposta Aceita:

91230

Postagem original de: dadioh ,

Título:

iMac 27" Black Screen

Texto:

iMac 27" 2009 i7 2.8GHz

I bought this machine and the V-Sync cable was damaged and during transit from the seller it stopped working due to the munched up 4 contact pads on the flex connector. I temporarily fixed it by using crazy glue under the tracks and pushing the contacts back down onto the plastic strip. Cleaned off the contacts and got the display back. However, I had to take it apart again and next time I reassembled it would not work. I received a replacement V-Sync cable from the seller and tested it with a multimeter. Contacts all in good shape (under my microscope). Replaced it but I still have a black screen.

Have reset SMC and PRAM, tried Command F2 to make sure I was not in display mode. Shining flashlight on screen it does not have an image so I do not think this is just a backlight issue. I also tried an external display and it also does not show an image.

If the backlight board was blown I am assuming it would not affect external display but when I had the bad cable initially it also would not display external. Can someone confirm if a bad backlight board could cause these symptoms? What is the most likely culprit? Maybe the 4850 graphics card? Could the Display Panel itself be damaged from this cable being defective? But that wouldn't explain no external display...

Open to ideas....

dispositivo:

iMac Intel 27 EMC 2309 and 2374

Status:

open