Skip to main content
Help

Current version by: Elliot ,

Title:

S7 Edge: No signs of booting - draws some power

Text:

Have two G935F phones that are both hard bricked. One draws 0.05mA when plugged in or whenever the USB cable is connected.

The other one does similar but sometimes draws around 0.30mA.

Attempted to use freeze spray on the latter to identify a short and it all evaporates at the same time.

Stereo Microscope inspection and shield removal reveals nothing out of the ordinary.

I have ZXW Tools

My question is where for Galaxy phone do you begin with these board problems, battery, screen and connector ports also replaced.

I’m familiar with iDevices a lot more so any help and advice would be really appreciated.

dispositivo:

Samsung Galaxy S7 Edge

Status:

open

Accepted Answer:

509432

Original post by: Elliot ,

Title:

S7 Edge: No signs of booting - draws some power

Text:

Have two G935F phones that are both hard bricked. One draws 0.05mA when plugged in or whenever the USB cable is connected.

The other one does similar but sometimes draws around 0.30mA.

Attempted to use freeze spray on the latter to identify a short and it all evaporates at the same time.

Stereo Microscope inspection and shield removal reveals nothing out of the ordinary.

I have ZXW Tools

My question is where for Galaxy phone do you begin with these board problems, battery, screen and connector ports also replaced.

I’m familiar with iDevices a lot more so any help and advice would be really appreciated.

dispositivo:

Samsung Galaxy S7 Edge

Status:

open