Ir para o conteúdo principal

Mensagem original de: William Green ,


Why is my MacBook Pro freezing after ~30 seconds?


The computer freezes after ~30 seconds. USB devices have power for a few moments after freezing and then power is cut. The fan still spins. The monitor still displays video. However, the computer is completely unresponsive.

I first attempted booting from a 500GB HDD preloaded with Lion, which has since been allocated for something else. I attempted booting and it would stall while loading the OS. I attempted verbose boot mode and there is nothing unusual. It simply stops logging messages after the computer freezes. The last message was "previous shutdown cause 3" for force shutdown. I force shutdown the computer each time is freezes.

I am able to access single user mode (Command+S).

After this failed, I attempted booting from my reliable flash drive. My flash drive has bootable installers for Leopard, Snow Leopard, Lion, and High Sierra.  Booting from the Leopard installer results in a kernel panic after booting for ~3 seconds. The High Sierra installer stalls after passing the halfway point. I have also tried network recovery for High Sierra but the result is the same.

I have tried booting to Apple's hardware test DVD. However, the computer abruptly shuts down immediately after the GUI appears. I can't read anything onscreen except I can see what appears to be a GUI interface.

I have tried disconnecting hardware to isolate the problem. I disconnected the trackpad, optical drive, sleep/hard drive cable, display, camera/mic, and the small cable immediately next to the keyboard cable. The problem still persists. I tested the monitor by plugging an optical mouse into a USB port, navigating the keys to boot Ubuntu and assumed the computer froze after the light on the mouse died.

I have also attempted PRAM and SMC resets.

I have also attempted booting Ubuntu from a bootable flash drive and the OS runs for ~30 seconds before the computer freezes. Everything is completely stable for those 30 seconds. I open the Resource Monitor program in Ubuntu to check processor and RAM resources and everything appears to be within normal range.

What else should I try? What could be causing this problem?

Thank you.


MacBook Pro 13" Unibody Mid 2010