Ir para o conteúdo principal

Conserte seus objetos

Direito de executar reparos

Peças e ferramentas

Ajuda

Versão atual de: tech4eleven ,

Texto:

i have the same issue. i replaced the screen of my t100ta-c2-edu and was super careful with all the hardware. the backlight comes on but theres nothing on the screen. I've re-seated the MB, video and battery cables a few times and they're all connected tightly. I've tried this key combination and others I've read about and i cant get anything to display. it was working fine before the screen was replaced. i hate to think this thing is now a paper weight but thats the way its looking :( any ideas?
 
=== Update (10/25/2017) ===
 
UPDATE: so the most insane thing I've ever seen and experienced in my IT career - the tablet needs to have the back cover on it in order for it to work. In my case anyway. I left the back cover off cause i wanted to make sure it was going to work before i snapped the cover on. I had given up on getting this to work after replacing the screen and trying everything i saw on the web to get it to show something on the screen and i snapped the cover back on and on a whim pressed the power button and it came on! nuts crazy. works like new. and ASUS wanted me to send it in for a $350 repair. no sir.

Status:

open

Mensagem original de: tech4eleven ,

Texto:

i have the same issue. i replaced the screen of my t100ta-c2-edu and was super careful with all the hardware. the backlight comes on but theres nothing on the screen. I've re-seated the MB, video and battery cables a few times and they're all connected tightly. I've tried this key combination and others I've read about and i cant get anything to display. it was working fine before the screen was replaced. i hate to think this thing is now a paper weight but thats the way its looking :( any ideas?

Status:

open