Ir para o conteúdo principal

Conserte seus objetos

Direito de executar reparos

Loja

Ajuda

Versão atual de: Maxime Laviolette ,

Texto:

Hey man,
 
I have the exact same problem with my G5. I forgot it was in my pocket and went in a salt water pool for about 2 minutes before I realized it was in my pocket. After putting it in a bag of rice for 3 days and let it dry on my table for another day, I decided to powered it on. Everything was working fine except my volume up key and the screen was dark (stuck at 30-40% brightness) and I had water bubble inside the screen.
 
The phone worked like that for about a week before I decided to replace the screen, thinking it would solved everything. I took everything apart again and cleaned all the contacts with 99% isopropyl alcohol. I used Qtips on all the contacts on the back cover and on the logic board. I was able to remove most of the white stuff "corrosion" by just lightly cleaning the contacts. I also cleaned the interior of the case and pretty much everything inside the phone, but very lightly.
 
After reassembly, my volume up key was now working again, my screen was replaced and working fine, but the brightness was still stuck at about 40%. So for sure, the problem comes from a part on the logic board, not the screen.
 
I will disassemble it again and clean more thoroughly as I wasn't able to remove all the "corrosion" the first time. I will also be a bit less gentle this time. Hopefully it fixes it like it did for my volume up key problem.
 
I think that is the only thing we can do at this point.
 
I'll let you know once I'm done with my second cleaning.
 
=== Update (07/14/2017) ===
 
Interestingly, I have "corrosion" at the exact same spot (between those 2 connectors) as you on your last picture.

Status:

open

Mensagem original de: Maxime Laviolette ,

Texto:

Hey man,

I have the exact same problem with my G5.  I forgot it was in my pocket and went in a salt water pool for about 2 minutes before I realized it was in my pocket. After putting it in a bag of rice for 3 days and let it dry on my table for another day, I decided to powered it on. Everything was working fine except my volume up key and the screen was dark (stuck at 30-40% brightness) and I had water bubble inside the screen.

The phone worked like that for about a week before I decided to replace the screen, thinking it would solved everything. I took everything apart again and cleaned all the contacts with 99% isopropyl alcohol.  I used Qtips on all the contacts on the back cover and on the logic board.  I was able to remove most of the white stuff "corrosion" by just lightly cleaning the contacts. I also cleaned the interior of the case and pretty much everything inside the phone, but very lightly.

After reassembly, my volume up key was now working again, my screen was replaced and working fine, but the brightness was still stuck at about 40%. So for sure, the problem comes from a part on the logic board, not the screen.

I will disassemble it again and clean more thoroughly as I wasn't able to remove all the "corrosion" the first time. I will also be a bit less gentle this time. Hopefully it fixes it like it did for my volume up key problem.

I think that is the only thing we can do at this point.

I'll let you know once I'm done with my second cleaning.

Status:

open