Ir para o conteúdo principal
Ajuda

Versão atual de: Jeffrey L ,

Título:

MacBook only powers on if power button held for 5 seconds

Texto:

I have a Macbook Pro 13" Retina Late 2013 (A1502 802-3476-A) and it suffered liquid damage from the previous owner. I managed to clean up the corrosion on the board and it is able to successfully boot but only if I hold the power button down for 5-10 seconds. If I simply push the button normally, the fan will spin briefly and the machine will power off before the Apple logo shows up. When it does boot, the clockspeed of the CPU is locked to 0.8GHz and it will never go up to its proper 2.4GHz so it runs really slow. This is likely because the 5 second power-on is an SMC check bypass and its doing so as a protection measure. Apple Hardware Diagnostics comes up with no issues.
I did observe corrosion around the ISL6259 (U7100) but I managed to clean it off, and since the computer is able to boot and charge the battery, I am assuming the chip itself is alright.
I've been reading the schematics and saw some advise elsewhere that I should be checking the pins on the ISL6259 but since I'm new at this, I am not sure where to start.
How would I know if there is a break in the trace? My continuity tests are coming up weird where I can touch two unrelated points such as pin 17 on the U7100 and any pin on the R7150 and it says there is continuity. And should I be checking for resistance, and if so, where?
Things I have validated:
- G3Hot is fine (otherwise it wouldn't power on) this far
- Pin 17 and 18 of ISL6259 U7100 give me 12.6V though I can touch them together and my continuity tester goes off (crappy tester perhaps?)
- Battery is charging fine, charger is fine
- SMC and NVRAM has been reset
- OS has been reinstalled
- All components have been plugged in, I have also removed the Trackpad/Keyboard connectors and attempted to boot to see if it makes a difference (it doesn't)
Sorry if this sounds all very amateurish, I decided to get this broken machine as a learning experience but right now I'm pretty stuck. Thanks!
'''Edit April 20:''' @rany Seems to be a break between pin 18 of the ISL and its associated Capacito/Resistor/Test Pad. It's going to be a challenge to reconnect this as the trace to the chip seems to be broken and I've never soldered something so small before. I am going to assume I might need to create a jumper between pin 18 and the test pad.
Any tips on how to do this preferably without a hot air station?
-[image|1093928]
+[image|1093928]
'''Edit April 21:''' @rany So I achieved some success. I was able to attach the jumper to the ISL pin 18 and the test point without any shorts. It's not pretty but it definitely works. My issue now is that the ISL gets extremely hot when I plug in the power (which is probably what burned the trace in the first place), I tested all the pins for shorts however it doesn't seem like anything is shorted. The resistance between pin 17 and 18 measures at 4.3ohms.
-[image|1096771][image|1096770]
+[image|1096771]
+
+[image|1096770]

dispositivo:

MacBook Pro 13" Retina Display Late 2013

Status:

open

Resposta Aceita:

+392269

Editado por: Jeffrey L ,

Título:

MacBook only powers on if power button held for 5 seconds

Texto:

I have a Macbook Pro 13" Retina Late 2013 (A1502 802-3476-A) and it suffered liquid damage from the previous owner. I managed to clean up the corrosion on the board and it is able to successfully boot but only if I hold the power button down for 5-10 seconds. If I simply push the button normally, the fan will spin briefly and the machine will power off before the Apple logo shows up. When it does boot, the clockspeed of the CPU is locked to 0.8GHz and it will never go up to its proper 2.4GHz so it runs really slow. This is likely because the 5 second power-on is an SMC check bypass and its doing so as a protection measure. Apple Hardware Diagnostics comes up with no issues.
I did observe corrosion around the ISL6259 (U7100) but I managed to clean it off, and since the computer is able to boot and charge the battery, I am assuming the chip itself is alright.
I've been reading the schematics and saw some advise elsewhere that I should be checking the pins on the ISL6259 but since I'm new at this, I am not sure where to start.
How would I know if there is a break in the trace? My continuity tests are coming up weird where I can touch two unrelated points such as pin 17 on the U7100 and any pin on the R7150 and it says there is continuity. And should I be checking for resistance, and if so, where?
Things I have validated:
- G3Hot is fine (otherwise it wouldn't power on) this far
- Pin 17 and 18 of ISL6259 U7100 give me 12.6V though I can touch them together and my continuity tester goes off (crappy tester perhaps?)
- Battery is charging fine, charger is fine
- SMC and NVRAM has been reset
- OS has been reinstalled
- All components have been plugged in, I have also removed the Trackpad/Keyboard connectors and attempted to boot to see if it makes a difference (it doesn't)
-Sorry if this sounds all very amateurish, I decided to get this broken machine as a learning experience but right now I'm pretty stuck. Thanks!
+Sorry if this sounds all very amateurish, I decided to get this broken machine as a learning experience but right now I'm pretty stuck. Thanks!
'''Edit April 20:''' @rany Seems to be a break between pin 18 of the ISL and its associated Capacito/Resistor/Test Pad. It's going to be a challenge to reconnect this as the trace to the chip seems to be broken and I've never soldered something so small before. I am going to assume I might need to create a jumper between pin 18 and the test pad.
-Any tips on how to do this preferably without a hot air station? [image|1093928]
+Any tips on how to do this preferably without a hot air station?
+
+[image|1093928]
+
+'''Edit April 21:''' @rany So I achieved some success. I was able to attach the jumper to the ISL pin 18 and the test point without any shorts. It's not pretty but it definitely works. My issue now is that the ISL gets extremely hot when I plug in the power (which is probably what burned the trace in the first place), I tested all the pins for shorts however it doesn't seem like anything is shorted. The resistance between pin 17 and 18 measures at 4.3ohms.
+
+[image|1096771][image|1096770]

dispositivo:

MacBook Pro 13" Retina Display Late 2013

Status:

open

Editado por: Jeffrey L ,

Título:

MacBook only powers on if power button held for 5 seconds

Texto:

I have a Macbook Pro 13" Retina Late 2013 (A1502 802-3476-A) and it suffered liquid damage from the previous owner. I managed to clean up the corrosion on the board and it is able to successfully boot but only if I hold the power button down for 5-10 seconds. If I simply push the button normally, the fan will spin briefly and the machine will power off before the Apple logo shows up. When it does boot, the clockspeed of the CPU is locked to 0.8GHz and it will never go up to its proper 2.4GHz so it runs really slow. This is likely because the 5 second power-on is an SMC check bypass and its doing so as a protection measure. Apple Hardware Diagnostics comes up with no issues.
I did observe corrosion around the ISL6259 (U7100) but I managed to clean it off, and since the computer is able to boot and charge the battery, I am assuming the chip itself is alright.
I've been reading the schematics and saw some advise elsewhere that I should be checking the pins on the ISL6259 but since I'm new at this, I am not sure where to start.
How would I know if there is a break in the trace? My continuity tests are coming up weird where I can touch two unrelated points such as pin 17 on the U7100 and any pin on the R7150 and it says there is continuity. And should I be checking for resistance, and if so, where?
Things I have validated:
- G3Hot is fine (otherwise it wouldn't power on) this far
- Pin 17 and 18 of ISL6259 U7100 give me 12.6V though I can touch them together and my continuity tester goes off (crappy tester perhaps?)
- Battery is charging fine, charger is fine
- SMC and NVRAM has been reset
- OS has been reinstalled
- All components have been plugged in, I have also removed the Trackpad/Keyboard connectors and attempted to boot to see if it makes a difference (it doesn't)
-Sorry if this sounds all very amateurish, I decided to get this broken machine as a learning experience but right now I'm pretty stuck. Thanks!
+Sorry if this sounds all very amateurish, I decided to get this broken machine as a learning experience but right now I'm pretty stuck. Thanks!
+
+'''Edit April 20:''' @rany Seems to be a break between pin 18 of the ISL and its associated Capacito/Resistor/Test Pad. It's going to be a challenge to reconnect this as the trace to the chip seems to be broken and I've never soldered something so small before. I am going to assume I might need to create a jumper between pin 18 and the test pad.
+
+Any tips on how to do this preferably without a hot air station? [image|1093928]

dispositivo:

MacBook Pro 13" Retina Display Late 2013

Status:

open

Mensagem original de: Jeffrey L ,

Título:

MacBook only powers on if power button held for 5 seconds

Texto:

I have a Macbook Pro 13" Retina Late 2013 (A1502 802-3476-A) and it suffered liquid damage from the previous owner. I managed to clean up the corrosion on the board and it is able to successfully boot but only if I hold the power button down for 5-10 seconds. If I simply push the button normally, the fan will spin briefly and the machine will power off before the Apple logo shows up. When it does boot, the clockspeed of the CPU is locked to 0.8GHz and it will never go up to its proper 2.4GHz so it runs really slow. This is likely because the 5 second power-on is an SMC check bypass and its doing so as a protection measure. Apple Hardware Diagnostics comes up with no issues.

I did observe corrosion around the ISL6259 (U7100) but I managed to clean it off, and since the computer is able to boot and charge the battery, I am assuming the chip itself is alright.

I've been reading the schematics and saw some advise elsewhere that I should be checking the pins on the ISL6259 but since I'm new at this, I am not sure where to start.

How would I know if there is a break in the trace? My continuity tests are coming up weird where I can touch two unrelated points such as pin 17 on the U7100 and any pin on the R7150 and it says there is continuity. And should I be checking for resistance, and if so, where?

Things I have validated:

- G3Hot is fine (otherwise it wouldn't power on) this far

- Pin 17 and 18 of ISL6259 U7100 give me 12.6V though I can touch them together and my continuity tester goes off (crappy tester perhaps?)

- Battery is charging fine, charger is fine

- SMC and NVRAM has been reset

- OS has been reinstalled

- All components have been plugged in, I have also removed the Trackpad/Keyboard connectors and attempted to boot to see if it makes a difference (it doesn't)

Sorry if this sounds all very amateurish, I decided to get this broken machine as a learning experience but right now I'm pretty stuck. Thanks!

dispositivo:

MacBook Pro 13" Retina Display Late 2013

Status:

open