Ir para o conteúdo principal
Ajuda

Versão atual de: Joel Spencer ,

Título:

Fan not turning on at system start - kboard + mouse errors

Texto:

Hey guys I recently opened this model to replace the hard drive and DVD drive. When taking it apart the previous mac engineer had placed the fan connector in an inaccessible location meaning when I tried to get it out I pulled a couple of the wires out from the plastic sheath (the cable that connects the fan to the motherboard).
I had the fan tested by an electronics specialist and it still works so I pushed the ends back in and they seemed okay. Just reassembled the PC and the fan didn't start when the system turned. I remember hearing that macbooks are mostly passively cooled so the fan won't always start, any confirmation on this?
Also the keyboard and mouse weren't working in the OS recovery environment. I plugged a usb mouse in which worked fine so it hadn't crashed. I'm right in thinking their connectors only go in one way yes?
+
+Update - 7/12/10
+
+First off I discovered this model is a 1.33GHz not 867mhz but from I used the 867 guide and it did not differ greatly. Got the keyboard and touchpad working in the end then spent a while trying to monitor temperatures (the usual tool Hardware Monitor doesn't support OS X 10.3) to see if the fan was working correctly.
+
+Then I discovered that the inbuilt hardware diagnostic tool on the OS X disc can tell you if there are any hardware errors. This reported back the error
+
+***error*code***error*code***
+2fan/4/1: Rear main enclosure
+***error*code***error*code***
+
+From which I deduce the fan is not working, all other features were working fine though (bluetooth, sound, display, wireless, lan, etc) so I am looking to acquire a new fan as can't find a replacement end for cheaper.
+
+I want to test the new hard drive I put in (as the packaging it was delivered in was not sufficient in my estimation) I've reinstalled the OS on the new drive and it seems stable but I'm a windows man so don't know which tools would work, would the Apple tools do a full surface scan?
+
+Finally does anyone know the full model number of the screen so I can look into the price of a new one.

dispositivo:

PowerBook G4 Aluminum 12" 867 MHz

Status:

open

Mensagem original de: Joel Spencer ,

Título:

Fan not turning on at system start - kboard + mouse errors

Texto:

Hey guys I recently opened this model to replace the hard drive and DVD drive. When taking it apart the previous mac engineer had placed the fan connector in an inaccessible location meaning when I tried to get it out I pulled a couple of the wires out from the plastic sheath (the cable that connects the fan to the motherboard).

I had the fan tested by an electronics specialist and it still works so I pushed the ends back in and they seemed okay. Just reassembled the PC and the fan didn't start when the system turned. I remember hearing that macbooks are mostly passively cooled so the fan won't always start, any confirmation on this?

Also the keyboard and mouse weren't working in the OS recovery environment. I plugged a usb mouse in which worked fine so it hadn't crashed. I'm right in thinking their connectors only go in one way yes?

dispositivo:

PowerBook G4 Aluminum 12" 867 MHz

Status:

open