Skip to main content
Help

Current version by: bjoern holst jespersen ,

Title:

power drops when disconnected from charger

Text:

Hi

a while ago I droped my iPod i water (with salt). After a some time it started to react but then froze.

I have now managed to take it apart, and have cleaned the logic board a little.

After putting it back together the navigating works again :) but only when the iPod is connected to my separate usb-charger :(

When I pull the plug the screen switches off, and when I reconnect to the charger, the iPod reboots.

When I switch it off while connected to charger, the display shows the "charging grafic".

Before I took it apart it only reacted to the hold-button, but the power didn't drop like that. Logic says I have made some mistake when reassembling, but it confuses me that all works with power from charger.

any suggestions?

dispositivo:

iPod Classic

Status:

open

Accepted Answer:

29991

Original post by: bjoern holst jespersen ,

Title:

power drops when disconnected from charger

Text:

Hi

a while ago I droped my iPod i water (with salt). After a some time it started to react but then froze.

I have now managed to take it apart, and have cleaned the logic board a little.

After putting it back together the navigating works again :) but only when the iPod is connected to my separate usb-charger :(

When I pull the plug the screen switches off, and when I reconnect to the charger, the iPod reboots.

When I switch it off while connected to charger, the display shows the "charging grafic".

Before I took it apart it only reacted to the hold-button, but the power didn't drop like that. Logic says I have made some mistake when reassembling, but it confuses me that all works with power from charger.

any suggestions?

dispositivo:

iPod Classic

Status:

open