Pular para o conteúdo principal
Ajuda

Postagem original de: Len ,

Texto:

Toshiba Satellite L870D Part# PSKBQC-00R001. Windows 7/64 Home Edition.

I had performed a clean install, updated all Windows then hardware drivers starting with the BIOS (to 6.30) and found single left USB slot worked but 2 on the right didn't. Device Manager showed no driver but I could see it was getting power as the light appeared in USB Flash Drive when inserted. Yes I tried the above solutions, and then some, but avoided editing the registry. Turned out I didn't need to!

Solution: The BIOS update (to 6.30) automatically defaulted the USB to 3.0, so, only the slot on the left would work as it is 3.0 compatible. I downloaded the Toshiba HW Utility which allows you to edit the BIOS and selected the 2.0 USB button. Problem solved, all USB slots are working. Yes the BIOS 6.30 update on the Toshiba Canada site is specified for Windows 8 but I have it working in Windows 7/64 no problem .... well, accept for the 3.0 issue.

Bonus fix! You probably also had this problem ... Device Driver for SM Bus Controller not found.

Solution: AMD SMBus Driver http://support.lenovo.com/us/en/downloads/ds019868

And always remember .... there will always be beer :P Cheers.

Status:

open