Pular para o conteúdo principal
Ajuda

Versão atual de: originalmachead and oldturkey03 (detalhes da votação) ,

Título:

SMC does not recognize battery, battery charge indi. lights dont work!

Texto:

I have similar problem. Im my case, if i bypass the SMC check at booting, the system runs fine on battery, although it does not recognize the battery, fan runs on full speed, and megasafe led on wall charger connector stays off the whole time. Which is normal considering SMC controls both battery management and fan speed. In this state, computer runs on battery without the charger connected.

When I run system through SMC check at booting like in normal booting. macbook wont run on just the battery, I have to connect adapter to use the macbook. The led light on megasafe wall charger connector stays green the whole time, it does not change to orange so it can charge battery. In both situations battery indicator lights on the side of macbook pro doesn't work. They don't work when I press the button, they don't work when I reboot the system like it used to. And yes, I cleaned the megasafe adapter, battery indicator wire is connected to the logic board. The white sleep led light flashes 5 times before booting up. The system won't recognize the battery, system info says:

Battery Information:

Charge Information:

Charge Remaining (mAh): 0

Fully Charged: No

Charging: No

Full Charge Capacity (mAh): 0

Health Information:

Cycle Count: 0

Battery Installed: No

Amperage (mA): 0

Voltage (mV): 0

- and the strange thing is battery indicator sometime has  black X on it or sometime it says 0%, and when this happens, system says:

Battery Information:

Charge Information:

Charge Remaining (mAh): 0

Fully Charged: No

Charging: No

Full Charge Capacity (mAh): 0

Health Information: Normal

Cycle Count: 0

Battery Installed: Yes

Amperage (mA): 0

Voltage (mV): 0

I did reset SMC quite a few time, no result. I did reset PRAM/NVRAM few time, no result.

I need help. My macbook pro is Mid 2009, so the warranty is out of the question. I replaced batteries like three times already, haven't found solution yet!

dispositivo:

MacBook Pro 13" Unibody Mid 2009

Status:

open

Resposta Aceita:

105608

Editado por: Titan ,

Título:

SMC does not recognize battery, battery charge indi. lights dont work!

Texto:

I have similar problem. Im my case, if i bypass the SMC check at booting, the system runs fine on battery, although it does not recognize the battery, fan runs on full speed, and megasafe led on wall charger connector stays off the whole time. Which is normal considering SMC controls both battery management and fan speed. In this state, computer runs on battery without the charger connected.
 
When I run system through SMC check at booting like in normal booting. macbook wont run on just the battery, I have to connect adapter to use the macbook. The led light on megasafe wall charger connector stays green the whole time, it does not change to orange so it can charge battery. In both situations battery indicator lights on the side of macbook pro doesn't work. They don't work when I press the button, they don't work when I reboot the system like it used to. And yes, I cleaned the megasafe adapter, battery indicator wire is connected to the logic board. The white sleep led light flashes 5 times before booting up. The system won't recognize the battery, system info says:
 
Battery Information:
 
Charge Information:
 
Charge Remaining (mAh): 0
 
Fully Charged: No
 
Charging: No
 
Full Charge Capacity (mAh): 0
 
Health Information:
 
Cycle Count: 0
 
Battery Installed: No
 
Amperage (mA): 0
 
Voltage (mV): 0
 
- and the strange thing is battery indicator sometime has black X on it or sometime it says 0%, and when this happens, system says:
 
Battery Information:
 
Charge Information:
 
Charge Remaining (mAh): 0
 
Fully Charged: No
 
Charging: No
 
Full Charge Capacity (mAh): 0
 
Health Information: Normal
 
Cycle Count: 0
 
Battery Installed: Yes
 
Amperage (mA): 0
 
Voltage (mV): 0
 
I did reset SMC quite a few time, no result. I did reset PRAM/NVRAM few time, no result.
I did reset SMC quite a few time, no result. I did reset PRAM/NVRAM few time, no result.
 
I need help. My macbook pro is Mid 2009, so the warranty is out of the question. I replaced batteries like three times already, haven't found solution yet!

dispositivo:

MacBook Pro 13" Unibody Mid 2009

Status:

open

Editado por: Titan ,

Título:

SMC does not recognize battery, battery charge indi. lights dont work!

Texto:

I have similar problem. Im my case, if i bypass the SMC check at booting, the system runs fine on battery, although it does not recognize the battery, fan runs on full speed, and megasafe led on wall charger connector stays off the whole time. Which is normal considering SMC controls both battery management and fan speed. In this state, computer runs on battery without the charger connected.
I have similar problem. Im my case, if i bypass the SMC check at booting, the system runs fine on battery, although it does not recognize the battery, fan runs on full speed, and megasafe led on wall charger connector stays off the whole time. Which is normal considering SMC controls both battery management and fan speed. In this state, computer runs on battery without the charger connected.
 
When I run system through SMC check at booting like in normal booting. macbook wont run on just the battery, I have to connect adapter to use the macbook. The led light on megasafe wall charger connector stays green the whole time, it does not change to orange so it can charge battery. In both situations battery indicator lights on the side of macbook pro doesn't work. They don't work when I press the button, they don't work when I reboot the system like it used to. And yes, I cleaned the megasafe adapteradapter, battery indicator wire is connected to the logic board. The white sleep led light flashes 5 times before booting up. The system doesn'twon't recognize the battery, system info says:
When I run system through SMC check at booting like in normal booting. macbook wont run on just the battery, I have to connect adapter to use the macbook. The led light on megasafe wall charger connector stays green the whole time, it does not change to orange so it can charge battery. In both situations battery indicator lights on the side of macbook pro doesn't work. They don't work when I press the button, they don't work when I reboot the system like it used to. And yes, I cleaned the megasafe adapteradapter, battery indicator wire is connected to the logic board. The white sleep led light flashes 5 times before booting up. The system doesn'twon't recognize the battery, system info says:
 
Battery Information:
 
Charge Information:
 
Charge Remaining (mAh): 0
 
Fully Charged: No
 
Charging: No
 
Full Charge Capacity (mAh): 0
 
Health Information:
 
Cycle Count: 0
 
Battery Installed: No
 
Amperage (mA): 0
 
Voltage (mV): 0
 
- and the strange thing is battery indicator sometime has black X on it or sometime it says 0%, and when this happens, system says:
 
Battery Information:
 
Charge Information:
 
Charge Remaining (mAh): 0
 
Fully Charged: No
 
Charging: No
 
Full Charge Capacity (mAh): 0
 
Health Information: Normal
 
Cycle Count: 0
 
Battery Installed: Yes
 
Amperage (mA): 0
 
Voltage (mV): 0
 
I did reset SMC quite a few time, no result. I did reset PRAM/NVRAM few time, no result. And yes, battery charge indicator light wire is connected to the logic board.
I did reset SMC quite a few time, no result. I did reset PRAM/NVRAM few time, no result. And yes, battery charge indicator light wire is connected to the logic board.
 
I need help. My macbook pro is Mid 2009, so the warranty is out of the question. I replaced batteries like three times already, haven't found solution yet!

dispositivo:

MacBook Pro 13" Unibody Mid 2009

Status:

open

Postagem original de: Titan ,

Título:

SMC does not recognize battery, battery charge indi. lights dont work!

Texto:

I have similar problem. Im my case, if i bypass the SMC check at booting, the system runs fine on battery, although it does not recognize the battery, fan runs on full speed, and megasafe led on wall charger connector stays off the whole time. Which is normal considering SMC controls both battery management and fan speed.

When I run system through SMC check at booting like in normal booting. The led light on megasafe wall charger connector stays green the whole time, it does not change to orange so it can charge battery. In both situations battery indicator lights on the side of macbook pro doesn't work. They don't work when I press the button, they don't work when I reboot the system like it used to. And yes, I cleaned the megasafe adapter. The system doesn't recognize battery, system info says:

Battery Information:

Charge Information:

Charge Remaining (mAh): 0

Fully Charged: No

Charging: No

Full Charge Capacity (mAh): 0

Health Information:

Cycle Count: 0

Battery Installed: No

Amperage (mA): 0

Voltage (mV): 0

- and the strange thing is battery indicator sometime has  black X on it or sometime it says 0%, and when this happens, system says:

Battery Information:

Charge Information:

Charge Remaining (mAh): 0

Fully Charged: No

Charging: No

Full Charge Capacity (mAh): 0

Health Information: Normal

Cycle Count: 0

Battery Installed: Yes

Amperage (mA): 0

Voltage (mV): 0

I did reset SMC quite a few time, no result. I did reset PRAM/NVRAM few time, no result. And yes, battery charge indicator light wire is connected to the logic board.

I need help. My macbook pro is Mid 2009, so the warranty is out of the question. I replaced batteries like three times already, haven't found solution yet!

dispositivo:

MacBook Pro 13" Unibody Mid 2009

Status:

open